1

I have an old laptop, on which I am planning to replace Windows with Arch Linux. I'm setting up Arch following the official wiki here.

After booting into the Arch ISO (BIOS mode), I got the virtual console, on which I ran iwctl to authenticate to the wifi network. However, on the [iwd] prompt, whenever I type device list, I get an empty list; no devices. I ran lsusb, and the drive is not there, too.

I am sure that a wifi drive IS there on my system, since the computer is able to connect to wifi in Windows. I have made sure that nothing is blocked by using rfkill, and I have tried retrying the installation from the beginning, still to no avail. Looking up online, I found a reddit thread, but no answers there work for me.

This is my first Arch installation, so I am not quite sure what else to do to fix this, so help would be appreciated. Thanks!

EDIT: I looked it up, my wifi driver is Intel Corporation PRO/Wireless 3945ABG [Golan]

PS: In case any extra information is needed which I haven't mentioned, do let me know, and I will update the question.

5
  • Are you set on Arch? Because if you just want to start using Linux I suggest starting with another distribution that has an installer. Arch is a great way of learning, but to get started you might want to use Debian or Fedora.
    – Thorian93
    Feb 3, 2021 at 16:48
  • @Thorian93 I'm quite set on Arch. I've been using Ubuntu for more than a year now, and I want to try this distro for learning :) Feb 3, 2021 at 19:12
  • Alright, just wanted to make sure. :) Could be a driver issue, can you provide more information on your hardware, specifically the WiFi Card? Also could you try and set everything up using LAN and handle the WiFi situation later? I am no Arch or hardware guru, so just trying to give hints here.
    – Thorian93
    Feb 4, 2021 at 8:02
  • Hey @Thorian93, sorry for the late response! My driver is Intel Corporation PRO/Wireless 3945ABG [Golan]. Also, I tried setting it up with LAN, still no luck. I guess the system's not detecting either of the drivers. Can it be an issue with the ISO file? Feb 5, 2021 at 10:40
  • Please update your question with the information so everyone can see it. :) I am not that much in the Arch setup process, but yes it sounds like a driver issue, but I don' think the iso is faulty. Maybe someone more Arch savvy can take it from here.
    – Thorian93
    Feb 5, 2021 at 15:07

1 Answer 1

1

I think you need to power on the adapter with this command:

adapter adapter set-property Powered on

In my case:

adapter phy0 set-property Powered on

This fixed my problem.

1
  • 3
    (1) Please show the command clearly and cleanly, and put commentary on a different line. (2) If the device doesn’t appear anywhere, how is the user supposed to know its name? Apr 20, 2022 at 18:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .