11

I am at my wits end here and could use some additional input. Long story short (more detail below), my system keeps throttling the CPU speed and I am unable to recover until I am able to unplug the battery of my laptop.


-> Description of Problem

Essentially, when all is cooperating, my CPU runs fine. I'm monitoring the CPU speed and usage with Conky and I can observe the frequency multiplier appropriately scaling based upon load. I also observe 'turbo' kick in under high load.

Then, without any discernible reason, my CPU throttles down to it's minimum of 400 MHz and remains at this level indefinitely. This includes after reboots or shutdowns - it will reboot into 400 MHz. If I push the CPU usage to 100% in this mode, it will remain at 400 MHz. I have attempted using cpufrequtils to force the CPU frequency and it does not move (sudo cpufreq-set -f `cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_max_freq). Also attempted resetting the cpufrequtils service with sudo /etc/init.d/cpufrequtils restart and the CPU remains throttled. I've now since removed cpufrequtils hoping that maybe itself was interfering with the CPU, but alas the problem remains. The only reliable method I've been able to use to recover the unit is disconnect the battery for a short period of time (1-2 minutes). As you might imagine, this is quite the pain.

Help?


-> System Info

Kernel: 5.8.0-41-generic

Distro: Ubuntu 20.04.2 LTS

CPU: 11th Gen Intel(R) Core(TM) i7-1185G7 @ 3.00GHz

Laptop Manf: MSI

Laptop Model: Prestige 15 A11SCX-002


-> Output of 'cpupower frequency-info'

analyzing CPU 0:
driver: intel_pstate
CPUs which run at the same hardware frequency: 0
CPUs which need to have their frequency coordinated by software: 0
maximum transition latency:  Cannot determine or is not supported.
hardware limits: 400 MHz - 4.80 GHz
available cpufreq governors: performance powersave
current policy: frequency should be within 400 MHz and 4.80 GHz.
                  The governor "powersave" may decide which speed to use
                  within this range.
current CPU frequency: Unable to call hardware
current CPU frequency: 1.60 GHz (asserted by call to kernel)
boost state support:
    Supported: yes
    Active: yes

Notes:

(1) I've tried adjusting the governor to performance to no avail - it does not appear to matter regarding the throttling.

(2) I cannot determine a reliable method to reproduce the issue. Sometimes it will throttle 10 minutes after initial boot or 3 hours after initial boot.

(3) I've tried various kernel versions (5.4 & 5.10 namely) and the issue persists.

(4) I've also tried adjusting the CPU driver by disabling via grub with intel_pstate=disable added to the GRUB_CMDLINE_LINUX_DEFAULT env variable. This forces my kernel to default to the acpi-cpufreq driver (confirmed with cpupower). Still the issue persists.

(5) Fast boot is disabled and I have no indications via BIOS that the BIOS is throttling my CPU as well.

6
  • have you checked the temperature?
    – Tch
    Commented Feb 3, 2021 at 1:08
  • Yes - temperatures are normal. i7z reports ranges from 30-40C . Commented Feb 3, 2021 at 13:29
  • It does not appear to get above 45C, however. I wonder if thermald is throttling? Commented Feb 3, 2021 at 13:51
  • Update: lm-sensors does not detect any fans. When I stress the cpu the core voltage goes from ~1.2V to ~0.6V and I do not physically observe any change in fan speed. I am thinking the kernel is unable to modulate the laptop cooling fan and perhaps this is where the throttling is coming from? Commented Feb 3, 2021 at 14:52
  • Cross posted as Intel CPU CONSTANTLY Throttled to Lowest Frequency - Ubuntu 20.04 on superuser. Usually you should pick one site to post on; probably you should delete this one. Commented Feb 3, 2021 at 18:57

4 Answers 4

3

I also have problem with my brand new DELL latitude 5420 (2021) with the same CPU (i7-1185G7) and Linux.

I temporary resolve the issue by running the commands below after system boot:

sudo rmmod intel_rapl_msr 
sudo rmmod processor_thermal_device 
sudo rmmod processor_thermal_rapl 
sudo rmmod intel_rapl_common 
sudo rmmod intel_powerclamp

sudo modprobe intel_powerclamp
sudo modprobe intel_rapl_common 
sudo modprobe processor_thermal_rapl 
sudo modprobe processor_thermal_device
sudo modprobe intel_rapl_msr 

EDIT: I tried a LIVE image of Ubuntu 20.04 and the problem disappeared! My basic Linux setup with the problem is Debian bullseye.

6
  • seems like fixed the issue. can you explain the reason or provide anything to refer to regarding the issue. Commented Jun 17, 2021 at 4:40
  • 2
    this worked for me too, XPS 13 2-in-1 (7390); having looked around a bit more, I removed the package thermald (sudo apt remove --purge thermald) and this seems to stop the excessive throttling issue and persist across reboots. Commented Jun 17, 2021 at 18:28
  • 2
    Adding an amendment to my above comment, I don't recommend uninstalling/disabling thermald beyond a quick diagnostic, as it's a "core" service to help keep the CPU from running too hot for too long - either a recent update to the 5.8.x kernel, thermald or BIOS seems to have caused this but I'm not sure which. Commented Jun 18, 2021 at 9:29
  • I experienced the same issue on a T490 with the i7-8565U; it suddenly started during a dist-upgrade. Stopping thermald with systemctl stop thermald fixed the throttling temporarily. Also, monitoring with s-tui did not show temperatures out of range. Commented Jul 10, 2021 at 13:02
  • I've got Dell Latitude 7430 with i5-1235U and blacklisting intel_rapl_common is enough for me to get rid of unbearable lags.
    – PocketSam
    Commented Feb 28, 2023 at 12:26
1

I encountered exactly the same issue with the same MSI laptop and a fresh install of Ubuntu 20.04 LTS. I tried everything but couldn't increase the CPU speed above 400 MHz. Sensors indicated no overheating issue or other reason for throttling. A coworker suggested I switch from Nvidia to Intel graphics, and so far that seems to have fixed the issue. I would say there should be no correlation, but so far it's working for me.

For the record, I simply typed sudo prime-select intel in a terminal window, then rebooted. Been running at normal speed since. If I ever need the Nvidia, I'm not sure what to do. I guess this is an MSI issue.

0

I was facing the same issue with a dual boot Ubuntu/Windows on a DELL Lattitude 7400. I've solved it by changing the "thermal management" of DELL Power Management in Windows to "Performance Ultra".

Then it seems to work so far on my Ubuntu.

It is explained at the bottom of the README.md from https://github.com/erpalma/throttled

0

Just to add my 2 cents, try running powerprofilesctl. Mine was set to power-save, resulting in often (not constantly) sub 1GHz cpu frequencies.

Setting powerprofilesctl set balanced or performance did the trick.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .