2

PrntScrn doesn't work and trying to open spectacle window with the command line gives me the following error:

$ spectacle
spectacle: error while loading shared libraries: libkColorPicker.so.0.1.4: cannot open shared object file: No such file or directory

I am using KDE Neon btw. It comes with spectacle preinstalled but there is also a snap package available so i tried installing that and it opens fine but this one doesn't. Any way to fix this?

3

Try this:

$ sudo apt install libkcolorpicker0=0.1.4-1+20.04+focal+build1
1
  • 1
    as soon as i do this, I get an update on Discover telling me that I need to update the same package. When I do update, spectacle stops working again. – Sbeve Sbren Feb 1 at 18:09
1
ln -s /usr/lib/x86_64-linux-gnu/libkColorPicker.so.0.1.5 /usr/lib/x86_64-linux-gnu/libkColorPicker.so.0.1.4

as a temporary solution

3
  • can you explain what this code does – Sbeve Sbren Feb 2 at 11:32
  • 1
    spectacle is trying to find libkColorPicker.so.0.1.4, but it is not exists, so application failed to start. ln -s creates symbolic link from version 0.1.5, which exists, to libkColorPicker.so.0.1.4 as alias. With such subsctitution spectacle works well – wingear Feb 2 at 14:04
  • Thank you. Spectacle just got an update and now it works perfectly. – Sbeve Sbren Feb 2 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.