1

After a reboot, suddenly Virtualbox will no longer start any virtual machines. The message I get for all the machines is:

Waiting for VM "win7" to power on...
VBoxManage: error: The virtual machine 'win7' has terminated unexpectedly during startup with exit code 1 (0x1)
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component MachineWrap, interface IMachine

The example is for Windows 7 machine, but the same is for Windows 10, Salix, Debian etc.

A brave attempt to upgrade to the current Virtualbox (6.1.18) did not help.

So, I uninstalled Virtualbox, rebooted, re-installed, ran sudo /sbin/vboxconfig and, ... same error.

The kernel module loads correctly, according to dmesg:

[ 1121.308187] vboxdrv: Found 6 processor cores
[ 1121.324431] vboxdrv: TSC mode is Invariant, tentative frequency 3000149185 Hz
[ 1121.324434] vboxdrv: Successfully loaded version 6.1.18 (interface 0x00300000)
[ 1121.534688] VBoxNetFlt: Successfully started.
[ 1121.536415] VBoxNetAdp: Successfully started.

modinfo vboxdrv shows that the module is the right version of Virtualbox and the correct version of the kernel.

The GUI starts normally, but I cannot start virtual machines from it; it provides the same error.

I also tried to create a new machine, to see if there was something wrong with the virtual boxes, but that did not work either.

My system is Salix, so not packages for VirtualBox exist. I've also tried the microlinux packages, but no avail.

I tried most of the solutions I could find on the Internet and Oracle's VirtualBox forum, but no avail. Does anyone here have additional hints, tips or solutions?

0

Still don't know what caused the original problem, but when I ran the VirtualBox installer via sudo, the ownership of /opt got changed from root to my user.

VirtualBox will throw this error also if /opt is not owned by root. Would have been nice to have a message saying /opt is not owned by root, instead of NS_ERROR_FAILURE (0x80004005). After a chown root /opt all the boxes started working again.

I uninstalled VirtualBox and re-installed it, and again , /opt changed owner, so it really is the installer script. I could not find the place in the script where /opt would change ownership.

0

For me the issue was that I tried starting it with simply vboxmanage startvm ExampleVM but I didn't have X forwarding working, so it would presumably try to create a display and fail. Adding --type headless fixed the issue:

vboxmanage startvm ExampleVM --type headless

Of course, this only applies if headless is what you want to do.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.