1

URXVT is writing over itself and leaving behind colored spaces... I feel like this is easier shown than described: urxvt overwriting

This started occurring overnight without making any changes, so I'm not sure where to even start diagnosing the issue. It does only occur in urxvt, no other applications, although I don't have any other terminal emulators to test on. I am using a picom branch that has rounded corners, which I forgot the name of but if it's useful I can probably find out, and this is the neofetch output if it's of any use: neofetch

Any ideas of what might be causing this issue or how to fix it? I haven't seen anything else regarding this issue, and it's not documented in the arch wiki either.

Thanks in advance!

3
  • Usually this happens if the terminal emulator renders characters at a different width than what fish expects. Does your prompt have any emoji or CJK characters? Does either of set -g fish_emoji_width 1 or set -g fish_emoji_width 2 help> Feb 2, 2021 at 3:48
  • I tried, but no luck... I should also note that I tried this in bash as well (which had been working before) and it has the same issue.
    – nani
    Feb 3, 2021 at 12:42
  • If you make your prompt extremely simple like just > does it still occur? Feb 5, 2021 at 1:20

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.