I am trying to boot Debian 10.7 from a usb drive. When I try to boot it said amdgpu requires firmware installed. I am using a AMD Ryzen 5 2400G processor (with Vega graphics). How do I fix this? Thanks in advance.

Also, I seem to be only able to access the terminal in recovery mode so all the "fixes" I tried will be attempted through the terminal in recovery mode.

I have attempted to search for a solution using google already. I came across the Debian website which provided a solution (https://wiki.debian.org/AtiHowTo)).

However, when I try to apply the solution, I can't complete the apt update part as when I try to execute that line in the terminal it outputs:

Could not resolve 'deb.debian.org'

I then thought it was maybe a network problem and I tried to ping google ( but the terminal said

Network is unreachable

I tried to search for a solution to that but every "fix" seemed to involved a command that I don't have and I can't really install anything since I can't connect to anything.

I am using ethernet and my internet was fine when Debian was installing (as it seemed to install successfully). I don't know what is going on, can someone help me please. Thanks in advance again.

3 Answers 3


If KDE fails to load on PC with AMD CPU/GPU, it can mean that Debian failed to ask if user want to install AMD firmware.

Try Alt+F5 keyb. shortcut when stuck on booting screen and login.

then run: apt install isenkram && isenkram-autoinstall-firmware

(may need to prefix these by "sudo " if logged in not as root)

It finds needed firmware and install it automatically https://packages.debian.org/buster/isenkram


Use the Debian installer image with non-free firmware included.


  • 1
    This will still be the case for Debian stable for a while. Still, quoting the linked page: "UPDATE 19 Feb 2023: As of the bookworm d-i alpha 2 release, firmware is included in the normal Debian installer images. USERS WILL NO LONGER NEED TO LOOK FOR SPECIAL VERSIONS HERE."
    – sampi
    Mar 24 at 12:52

I had the same issue. Followed the steps on https://wiki.debian.org/AtiHowTo and it solved, even if I could not perform step 2.

For step 4, I downloaded all the packages into a pen and plugged it to the pc before running the command indicated.

Thank you for posting your situation that drove me to the link. Hope you can solve your situation fast.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .