3

Problem

I want to start Ubuntu in recovery mode because it won't boot normally.

I have three options in my GRUB selection screen: grub selection menu If I press the down arrow on my keyboard, the selection moves all the way to the bottom of the list (Windows 10), and if I press the up arrow it goes all the way to the top (Ubuntu).

Another thing which happens is that if I press the arrow keys a couple times the computer appears to crash, or it stops handling keyboard inputs at all.

Details

  • I'm running GRUB v2.02
  • I recently ran the boot-repair utility which reinstalled GRUB, and have done this a couple times, each time with the same result
  • Here's a link to a Boot Repair summary

Question

How can I can start Ubuntu in recovery mode?

15
  • Have you run sudo update-grub ? Its almost as if you have Advanced options a a title, but not the sub-menu items under which should be recovery mode & second kernel & its recovery mode. Did you make any other changes to grub? or grub scripts? If so you may need total reinstall of grub, but that will depend on if UEFI or BIOS version.
    – oldfred
    Jan 31, 2021 at 15:28
  • I've reinstalled GRUB twice using the boot-repair utility with recommended options
    – karobar
    Feb 1, 2021 at 1:38
  • Post link to Summary Report from Boot-Repair.
    – oldfred
    Feb 1, 2021 at 3:28
  • Are you using a keyboard that is special in some way? For example, some gaming keyboards implement N-Key Rollover (the capability to recognize an unlimited number of keys pressed simultaneously) by appearing on the USB bus as multiple keyboards, to work around USB HID protocol limitation. If poorly implemented, that might cause problems with USB keyboard support of the system firmware, which is used by GRUB.
    – telcoM
    Feb 1, 2021 at 9:17
  • 1
    Same behaviour with Ctrl+p and Ctrl+n?
    – Freddy
    Feb 2, 2021 at 16:18

3 Answers 3

2

I resolved this issue by updating my BIOS.

My motherboard is a "Fatal1ty AB350 Gaming-ITX/ac" and I updated the BIOS version from 5.70 to 6.60

1
  • Worked for me on ASUS TUF B450M-PRO GAMING, I updated my BIOS from v2006 to v3604 and now the keyboard works fine in GRUB.
    – nupanick
    Apr 13, 2022 at 23:06
1

If you are able to the other buttons of the keyboard, then once you are on Ubuntu press the letter "e", go down to

linux   /BOOT/ubuntu........ro quiet splash ....
initrd  /BOOT/......

remove "quiet splash" and any thing like "${vt_handoff}" and replace it with "recovery nomodeset dis_ucode_ldr" and press F10 or ctrl+x.

recovery: boot into recovery.

nomodeset: disable graphic drivers.

dis_ucode_ldr is disable microcode. look@https://wiki.debian.org/Microcode

After F10, you will boot into recovery mode.

2
  • This would not work as I was getting duplicated keyboard inputs within GRUB's editor making adding these lines impossible
    – karobar
    Feb 8, 2021 at 16:00
  • 1
    Then your problem could be connected with hardware. Try to use another keyboard, or update the firmware (BIOS) or reinstall it if that possible.
    – kasa
    Feb 8, 2021 at 16:03
0

This issue began happening to me due to a BIOS and CPU upgrade; I definitely changed no GRUB settings.

It seems to be a bad interaction between GRUB and some BIOS keyboard drivers.

I'm stuck with a puke-awful MSI motherboard and they have no working BIOS version compatible with this CPU. However, I did find a workaround:

This motherboard still features a PS/2 port, and I still have a spare PS/2 keyboard. The PS/2 keyboard works correctly to access the recovery console.

If you're desperate, another workaround would be to temporarily put the boot device in a different computer.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .