0

I just installed WSL2 on my Windows 10 computer running Ubuntu 20.04. I already have WSL1 with Ubuntu 18.04 with a plethora of files and functions that I'd now like to use with my system in WSL2. I moved a single numpy folder over and my .bashrc script over as well. However, now whenever I try to move over a new folder, my command line tells me

-bash: cd: rootfs/david/home/*folder name*: Permission Denied

I've tried using sudo cd, but that gives me an error as well. I'm copying over the content using the directory location on windows, i.e.

cd /mnt/c/User/*User Name*/AppDate/Local/Packages/CanonicalGroupLimited.Ubuntu18.04onWindows_79rhkp1fndgsc/LocalState/rootfs/...

Did I screw something up in WSL2 setup? All I ultimately want to do is get the setup I had in WSL1 environment working in my WSL2 setup.

3
  • WSL seems to suffer with file-permissions that are out of its control. They are on he host system. – ctrl-alt-delor Jan 30 at 10:16
  • If you cd to /mnt/c/User/*User Name*/AppDate/Local/Packages/CanonicalGroupLimited.Ubuntu18.04onWindows_79rhkp1fndgsc/LocalState/rootfs/... one directory at a time, on which directory does the cd fail? – Mark Plotnick Jan 30 at 11:35
  • @MarkPlotnick It won't let me do anything in ./rootfs/. I try to cd to that directory and I don't have permission, no tab complete or anything. If I verbatim write the path to a subdirectory, it still says I have no permission. – David G. Jan 31 at 20:25
2

Whatever I understood from your question is that you want to convert your WSL1 system to WSL2 system.

First to check the name of the distribution ("Ubuntu 10.04" must be a typo in the question).

wsl --list --verbose

Note the name of the distribution you want to convert to WSL2 and use the following command to convert:

wsl --set-version <distribution name> 2

The number written at the end of the command is the WSL version. You can write either 1 or 2 there.

4
  • So my WSL1 is in Ubuntu 18.04 and my WSL2 is in Ubuntu 20.04, I would like to using a WSL environment in Ubuntu 20.04. If I go to my WSL1 environment and do this, it will still be in 18.04, correct? – David G. Jan 31 at 20:19
  • if you convert your WSL version of Ubuntu 18.04 from 1 to 2, it will still stays the same Ubuntu 18.04. So yes it is correct. – Kuldeep Singh Feb 1 at 19:13
  • So I ended up converting my WSL 1 distribution from Ubuntu 18.04 to 20.04, then I switched that over from WSL 1 to WSL 2. I don't know why the tutorial I first looked up had me set up a new WSL environment to run WSL 2. – David G. Feb 1 at 19:28
  • glad it solved your problem. – Kuldeep Singh Feb 2 at 5:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.