I’m trying to install material shell which is only in unstable right now.

I’m using the guide from the wiki to install a package from unstable along with this post on adding unstable without using a channel.

The configuration looks like:

  unstableTarball =

  nixpkgs.config = {
    packageOverrides = pkgs: {
      unstable = import unstableTarball {
        config = config.nixpkgs.config;

  # List packages installed in system profile. To search, run:
  # $ nix search wget
  environment.systemPackages = with pkgs; [


I am able to install gnome extensions from 20.09 with no errors. I am able to install packages from unstable with no errors. When I try to install “unstable.gnomeExtensions.material-shell” I get the following build error:

building Nix...
building the system configuration...
error: attribute 'material-shell' missing, at /cfg/configuration.nix:102:5
(use '--show-trace' to show detailed location information)

I’ve tried installing through both environment.systemPackages in my configuration.nix and my home.packages in my home.nix.

Do I need to use a different package name to get this to work?

  • Did you update the unstable channel? For NixOS configuration, you will need to update it with sudo.
    – Jan Tojnar
    Jan 30, 2021 at 15:11
  • I've added some more detail to clarify. I'm using the unstable tarball in the configuration rather than setting the channel up outside my configuration.nix. A full example is now in the post.
    – ciferkey
    Jan 30, 2021 at 16:50

1 Answer 1


https://github.com/NixOS/nixpkgs-channels repository has been deprecated and is no longer updated; the channel branches are now part of the main repo. You will need to switch to https://github.com/NixOS/nixpkgs/archive/nixos-unstable.tar.gz

  • This resolved the issue! Thanks.
    – ciferkey
    Jan 31, 2021 at 1:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .