0

After installing Pop OS 20.04 the internal mic stopped working in my Lenovo IdeaPad 330-15ARR laptop. What have I tried ? I'd referred to the official wiki here : All kinds of troubleshooting for audio related issues which was given in following post's answer. The workarounds helped to some extent but the annoying distortion sound still didn't stopped.

2 Answers 2

0

I found the solution on my own ! It's divided into two parts as follows:

A brief about the background : Being not that much experienced with the bash commands to alter a certain string in multiple files which I think surely exists, I'd to do a lot of tedious work (Mightn't be that much tedious for you LOL). So the solution was to use the following command to so as to edit all the configuration files of pulse audio and alter each one of them individually (at least in my case). As mentioned in the post's answer above the path of files to be edited is : /usr/share/pulseaudio/alsa-mixer/paths/analog-input*.conf and not (as said in the wiki article) i.e: /usr/share/alsa-card-profile/mixer/paths/analog-input*.conf obviously because both of them point to configuration files of two different softwares (Pulse Audio & ALSA). So I worked with the post answer's config files. You can see and work with the ones which apply to your case.

  1. First part (To get the mic in working state):

After doing what's been told above do the following :

  • Install pavucontrol (if not already) using : sudo apt install pavucontrol
  • Do as instructed here
  • Open pavucontrol and check if Remapped...(there will be something more written with it but you just have to look for Remapped) entry is showing up under Input Devices or not.
  • If it's there then open Settingsand search Sound then change input to Remapped option under Input section.
  • If it's not showing then revisit the link and make sure you followed all the steps carefully !
  1. Second part (TO FIX DISTORTION):
  • Use the command : sudo gedit /usr/share/pulseaudio/alsa-mixer/paths/analog-input*.conf (This will open all the config files at once in gedit)

  • Now, you've to edit each file look for the keys mentioned here and change their values to zero not number but zero as a word. Don't change the value of 'Element Capture' or just try and see if it's needed or not for me it worked without setting the value of 'Element capture' to zero.

That's it I hope it'll help someone like myself I'll also make a youtube video & will give it's link here to make it easier for you guys to follow the steps asap.

0

Here is the best solution I found. TiVP's last answer is the one that has images that guide you what to do. https://github.com/pop-os/pipewire/issues/8

2
  • I recommend that once fixed, you do not modify the volume with POP! OS. If you do, you will have to reboot or run the command alsactl --file ~/.config/asound.state restore. Just modify it with QasMixer. Jun 25, 2022 at 1:06
  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review Jun 25, 2022 at 4:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .