0

I just bought an NVME Team group MP33 SSD hard drive. When I format the partition with NTFS or FAT32 it works fine but when I try to format the root partition with ext4, my computer crashes for two to five minutes and displays some errors and I can't find the NVME SSD until I reboot.

The error is

blk_update_request: I/O error, dev nvme0n1, sector xxxxxxxxxxxxxxx op x09:(WRITE_ZEROES) flag 0x1000000 phys_seg 0 prio class 0

Is the problem with the SSD or I just miss something (I don't think because I tried with Debian, Archlinux and GParted live iso with GPT partition table).

2 Answers 2

0

Maybe it is due to the drive being overwhelmed by TRIM requests. Try formatting it with mkfs.ext4 -K (which skips trimming).

1
  • the same problem I found an old CD of Debian 9 when I installed it worked, Now I'm using this CD to make the file system and then I switched to my arch iso and I'm installing it :/
    – blocus
    Jan 20, 2021 at 21:37
0

The issue is trimming your disk, I had a similar issue on RDM mapped disks. After creating the FS with mkfs.ext4 I got timeouts and NVMe controller was deleted.

This seems not a kernel solved issue and already actuall on all Linux related kernels.

[3651261.749386] nvme 0000:14:00.0: irq 97 for MSI/MSI-X
[3651261.749386] nvme 0000:14:00.0: irq 97 for MSI/MSI-X
[3651292.714935] nvme nvme0: I/O 89 QID 1 timeout, disable controller
[3651292.738695] blk_update_request: I/O error, dev nvme0n2, sector 2048
[3651292.738785] nvme nvme0: failed to mark controller state 1 [3651292.738788] nvme
nvme0: Removing after probe failure status: 0

Solution:

Use: mkfs.ext4 -K /dev/VG/LV /mountpoint

-K

Keep, do not attempt to discard blocks at mkfs time (discarding blocks initially is useful on solid state devices and sparse / thin-provisioned storage).

You must log in to answer this question.