0

I'm setting up decrypt over ssh and have successfully created an initramfs I can boot into. currently though, whether pasted or typed manually, my password fails to be accepted, but I've confirmed that the password is correct by decrypting and chrooting into the partition from a user account located on another root via:

sudo cryptsetup luksOpen /dev/sda2 crypt &&\
sudo mount -t btrfs -o subvol=rootfs /dev/mapper/crypt  root/ &&\
for i in /sys /proc /run /dev; do sudo mount --bind "$i" "~/root/$i"; done &&\
sudo chroot ~/root

this is also how I'm generating the initramfs, which is then being copied to the appropriate boot partition and pointed to by the /boot/config.txt

I have cryptsetup enabled via setting CRYPTSETUP=y in /etc/cryptsetup-initramfs/conf.hook

I have confirmed that the uuid for the encrypted device is correct in the intramfs's copy of cryptab.

I've confirmed via cat /proc/cmdline.txt that the kernel parameters are pointing to the appropriate partition cryptdevice=/dev/sda2:crypt in the initramfs

I'm not exactly sure what's missing, or what's going wrong. I can use other commands from the initramfs, and I don't see an issue with any characters not being recognized. cryptroot-unlock doesn't seem to have any options like --verbose

Note: this is Raspberry OS on the pi, but I'm 85% sure this isn't a pi issue, hence posting here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.