1

i would like some help, please.

I'm new to PC's and trying to install fedora 32, dual boot with windows 10 in my acer aspire 3.

I've flashed the ISO in the USB, made a 20gb partition on the hard disc, and disabled fast boot and secure boot.

The computer recognizes the installer, and when i choose the "install fedora" option, it freezes in the next session, as you will see in the picture. The loading "*" stops moving and the "|" stops flashing. I've waited for several minutes and nothing. Coudn't find an specific solution to this problem... Any help?

  • I've tried three times to install it and it freezes in the same point

image of the installator when it freezes

4
  • May be the files on installer USB are problematic. I faced such hang issue in past with OS due to corrupt installer disks – Sapan Vashishth Jan 28 at 16:43
  • Dear Sapan, ive tried to install it with fedora's own installer and with balenaetcher. Faced the same problem both times – Eduardo Jan 28 at 16:50
  • What kind of video card? I remember something from a while ago where certain AMD graphics cards had an issue with firmware-amdgpu that caused a system freeze upon trying to activate higher graphics modes while booting under UEFI. – Shadur Jan 29 at 15:03
  • Shadur, It's an AMD Radeon Vega 8 Graphics... remember if there was a way to solve it? – Eduardo Jan 30 at 18:53
1

Please try Fedora 33. Fedora 32 will be EOL'ed in May 2021, so there's very little sense in trying to install it. The newer the Fodora release is, the newer kernel it contains which means better support for more devices.

Also disabling secure boot is not necessary. If your OEM is decent enough your device must have a secure boot key for Fedora (HP does - I'm running Fedora on it with Secure Boot enabled).

7
  • Dear Artem, Thanks for your reply! But i've checked and it is fedora33 (1.2) that i've tried. I'm sorry, but what is "OEM"? – Eduardo Jan 28 at 16:49
  • 2
    We need to stop normalizing the idea of "Just disable secure boot", it is a critical security mechanism and should be encouraged to the highest degree, and made to be a streamlined process (it usually is unless you want to load custom kernel modules). See media.defense.gov/2020/Sep/15/2002497594/-1/-1/0/… – john doe Jan 28 at 16:59
  • @Eduardo Try adding intel_iommu=off as your kernel parameter before booting. I've found people who experience the same issue but there's no resolution: dell.com/community/XPS/… – Artem S. Tashkinov Jan 28 at 17:50
  • Artem, I've tried it and it didn't work. I've tried with ubuntu, linux mint, and they all freeze during the instalation... guess windows it is – Eduardo Jan 29 at 22:19
  • 1
    @terdon Disabling Secure Boot should not be necessary at all on Fedora; it should just work in almost all (x86) cases. The major exception is when you want to load a proprietary kernel module, and we can't do anything about that. – mattdm Feb 1 at 22:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.