1

I switched from SysVInit to systemd on my VPS and the file system has been mounted read-only ever since. Remounting the file system with mount -o remount,rw / works, but the file system is mounted read-only again on reboot.

To install systemd, I ran:

apt install systemd
apt install systemd-sysv

To date, I have tried:

  • Reinstalling systemd and systemd-sysv
  • Reinstalling init after seeing this message when running apt install systemd-sysv:
dpkg: sysvinit-core: dependency problems, but removing anyway as you requested:
 init depends on systemd-sysv | sysvinit-core; however:
  Package systemd-sysv is not installed.
  Package sysvinit-core is to be removed.
  • Uninstalling old packages that were required by SysVInit (apt autoremove)

I've looked around but I can't seem to find a solution. I read that Linux systems occasionally do this to protect your data when they encounter errors, so I've included the output from dmesg. Other users seem to experience similar issues when there are problems with storage, but I haven't seen any of the same messages they saw when running fsck.

Output from dmesg: https://pastebin.com/zrRzMqLd

Output from fsck:

fsck from util-linux 2.36.1

Any help would be appreciated. I'm a relatively experienced GNU/Linux user but I know very little about what happens when a Linux system boots (or why it goes wrong).

0

With the help of a (more experienced) friend, I came to the conclusion that the issue was caused by a missing /etc/fstab file. It may have been deleted by one of my apt operations. This fixed the problem:

  1. Remount the filesystem as read-write with mount -o remount,rw /.
  2. Run blkid as root.
  3. For each device listed, copy the corresponding line from /proc/mounts to /etc/fstab (the line should begin with the same device name/UUID). Do NOT copy the entire /proc/mounts file to /etc/fstab.

For more on /etc/fstab: https://www.howtogeek.com/howto/38125/htg-explains-what-is-the-linux-fstab-and-how-does-it-work/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.