I'm running Fedora 18 on a Toshiba laptop with the notorious RTL8723 wireless card. I've been able to compile the driver using lwfinger's instructions from this forum thread here

wget http://linuxwireless.org/download/compat-wireless-2.6/compat-wireless-2012-10-03.tar.bz2
wget http://www.lwfinger.com/realtek_drivers/rtl8723ae_master_patch
tar jxvf compat-wireless-2012-10-03.tar.bz2
cd compat-wireless-2012-10-03/
patch -p1 < ../rtl8723ae_master_patch
sudo make install
sudo modprobe -v rtl8723ae

After performing these steps the device can indeed see the available wireless networks. The problem appears when I actually try to connect to one of the WPA2-secured ones -- the Gnome network manager keeps asking me for authentication and refuses to establish the connection. I take it I should now figure out whether this is a driver issue or a network manager issue (or something else) but I'm not sure how to proceed.

EDIT: It appears that the problem isn't with the network manager after all: after disabling Network Manager I tried running wpa_supplicant from the terminal, and all I got in response were the following messages, which just kept coming:

wlan0: Trying to associate with 7c:4f:b5:8e:a0:87 (SSID='mynetwork' freq=2462 MHz)
ioctl[SIOCSIWFREQ]: Device or resource busy
wlan0: Association request to the driver failed
wlan0: Associated with 7c:4f:b5:8e:a0:87
wlan0: Authentication with 7c:4f:b5:8e:a0:87 timed out.
wlan0: CTRL-EVENT-DISCONNECTED bssid=00:00:00:00:00:00 reason=0
wlan0: Trying to associate with 7c:4f:b5:8e:a0:87 (SSID='mynetwork' freq=2462 MHz)
ioctl[SIOCSIWFREQ]: Device or resource busy
wlan0: Association request to the driver failed
wlan0: Associated with 7c:4f:b5:8e:a0:87

I already solved the problem, to avoid this:

[root@dhcppc2 compat-wireless-2012-12-18]# make
./scripts/gen-compat-autoconf.sh /home/kiwi/compat-wireless-2012-12-18/.config /home/kiwi/compat-wireless-2012-12-18/config.mk > include/linux/compat_autoconf.h
make -C /lib/modules/3.7.5-201.fc18.x86_64/build M=/home/kiwi/compat-wireless-2012-12-18 modules
make: *** /lib/modules/3.7.5-201.fc18.x86_64/build: No such file or directory.  Stop.
make: *** [modules] Error 2

I had to install the kernel-devel pack, I did it through yum:

yum install kernel-devel

But to fix the wirelesss problem I did the following:

  1. I downloaded the latest version of compat-wireless here, in my case I downloaded this one: compat-wireless-2012-12-18.tar.bz2.

  2. Then after entered with a terminal into the directory where I saved the file I typed this:

tar -xjvf compat-wireless-2012-12-18.tar.bz2
cd compat-wireless-2012-12-18
make install
  1. Once installed, to test the driver I needed, which is rtl8723ae I typed this:

modprobe rtl8723ae

...and the wireless worked well. Then I restart the computer and now the wireless is working properly.

  • The latest compat wireless (now renamed to compat-drivers) is at kernel.org/pub/linux/kernel/projects/backports/2013/02/02 – BatchyX Feb 9 '13 at 10:42
  • It is best not to rely on third-party pieces... – vonbrand Feb 9 '13 at 16:43
  • @user32054 your solution can be summed up as "use a newer version of compat-wireless", which i did. i'm still getting asked for authentication time after weary time. to repeat, the problem is not that the device can't see the networks; rather, i can't connect to the one i'd like to connect to. – Pavel Rudnev Feb 10 '13 at 12:21
  • @user32054 funny enough, your solution worked for exactly two days, and now i'm back to being repeatedly asked for authentication every 10 seconds. you say wireless is working well on your machine. how long does it take it to establish the connection? – Pavel Rudnev Feb 12 '13 at 20:31

I tried it, but using backports 4.4.2-1, the new version of compat. My terminal shows me an error using backports. Well, so I thought... maybe if I use make oldconfig, my fedora will reset the configuration and compile all drivers again showing to me options to do it in the screen. Well, I was correct, and because that, I actived all drivers and turn off power saving settings do wifi. Afther that, I rebooted my notebook and in the start, my Fedora 25 install every drive again and make my choices in the .config file.

  • Welcomm to U&L, I edited you post to fix misc typos, however; I am not sure this could of practical use. – Archemar Dec 5 '16 at 11:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.