0

I would like to be able to choose kernel on boot up. I have installed arch default and lts kernel. I am using systemdboot as boot loader.

But when I start my notebook it directly starts booting without showing any menu. When I run uname -r I get:

5.9.0-arch1-1

in /boot/loader/entries/ I have two files:

arch.conf

title Arch Linux
linux /vmlinuz-linux
initrd /intel-ucode.img
initrd /initramfs-linux.img
options root="LABEL=arch_os" rw

and arch-lts.conf

title Arch Linux (LTS)
linux /vmlinuz-linux-lts
initrd /intel-ucode.img
initrd /initramfs-linux-lts.img
options root="LABEL=arch_os" rw

in /boot I have:

drwxr-xr-x 7 root root 4.0K 11. pro 11.08  EFI/
-rwxr-xr-x 1 root root  28M 26. led 16.39  initramfs-linux-fallback.img*
-rwxr-xr-x 1 root root 7.6M 26. led 16.39  initramfs-linux.img*
-rwxr-xr-x 1 root root  28M 25. led 16.19  initramfs-linux-lts-fallback.img*
-rwxr-xr-x 1 root root 7.7M 25. led 16.19  initramfs-linux-lts.img*
-rwxr-xr-x 1 root root 3.5M 19. lis 08.58  intel-ucode.img*
drwxr-xr-x 3 root root 4.0K 27. led 19.34  loader/
drwxr-xr-x 2 root root 4.0K 29. čec  2020 'System Volume Information'/
-rwxr-xr-x 1 root root 8.6M 26. led 16.39  vmlinuz-linux*
-rwxr-xr-x 1 root root 6.2M 25. led 16.19  vmlinuz-linux-lts*

When I run bootclt I get:

System:
     Firmware: UEFI 2.60 (Lenovo 0.6032)
  Secure Boot: disabled
   Setup Mode: setup
 Boot into FW: supported

Current Boot Loader:
      Product: systemd-boot 245.7-1-arch
     Features: ✓ Boot counting
               ✓ Menu timeout control
               ✓ One-shot menu timeout control
               ✓ Default entry control
               ✓ One-shot entry control
               ✓ Support for XBOOTLDR partition
               ✓ Support for passing random seed to OS
               ✓ Boot loader sets ESP partition information
          ESP: /dev/disk/by-partuuid/734e58b8-003a-4faf-bb75-338274e3fe64
         File: └─/EFI/systemd/systemd-bootx64.efi

Random Seed:
 Passed to OS: yes
 System Token: set
       Exists: yes

Available Boot Loaders on ESP:
          ESP: /boot (/dev/disk/by-partuuid/734e58b8-003a-4faf-bb75-338274e3fe64)
         File: └─/EFI/systemd/systemd-bootx64.efi (systemd-boot 245.7-1-arch)
         File: └─/EFI/BOOT/bootx64.efi (systemd-boot 245.7-1-arch)

Boot Loaders Listed in EFI Variables:
        Title: Linux Boot Manager
           ID: 0x0002
       Status: active, boot-order
    Partition: /dev/disk/by-partuuid/734e58b8-003a-4faf-bb75-338274e3fe64
         File: └─/EFI/systemd/systemd-bootx64.efi

        Title: Windows Boot Manager
           ID: 0x0000
       Status: active, boot-order
    Partition: /dev/disk/by-partuuid/734e58b8-003a-4faf-bb75-338274e3fe64
         File: └─/EFI/Microsoft/Boot/bootmgfw.efi

        Title: Linux-Firmware-Updater
           ID: 0x0001
       Status: active, boot-order
    Partition: /dev/disk/by-partuuid/734e58b8-003a-4faf-bb75-338274e3fe64
         File: └─/EFI/arch/fwupdx64.efi

Boot Loader Entries:
        $BOOT: /boot (/dev/disk/by-partuuid/734e58b8-003a-4faf-bb75-338274e3fe64)

Default Boot Loader Entry:
        title: Arch Linux
           id: arch.conf
       source: /boot/loader/entries/arch.conf
        linux: /vmlinuz-linux
       initrd: /intel-ucode.img
               /initramfs-linux.img
      options: root="LABEL=arch_os" rw

How can I achieve state in which I can choose kernel on boot in bootmenu ? How can I make boot menu show on first place ?

If you need any more information comment under this post and I will add them soon as possible.
Thank you for help

1 Answer 1

0

Solution was to set timeout parameter in /boot/loader/loader.conf:

default arch.conf
timeout 5
console-mode max
editor no

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.