0

I have a Brother printer with following configuration:

Description:    Brother HL-L2360D series
Location:   localhost.localdomain
Driver: Brother HL-L2360D for CUPS (grayscale, 2-sided printing)
Connection: usb://Brother/HL-L2360D%20series?serial=E73799L0N424480

It is connected via USB on my fedora 30 OS.

To configure , I performed following steps:

  1. Installed lpr and cups driver from here
  2. Ran "system-config-printer"
  3. Clicked on add printer - printer got detected and added
  4. Print test page worked as well

Now the issue is when I open system settings and go to printer menu, it says no printer available. Also, I tried printing some documents but no printer is detected and it saves then on PDF only. Although printer is added and self test worked but its still not getting detected by libre office/system.

Tried this solution How do I get Brother printer drivers to work on Fedora? , but did not work for me.

1 Answer 1

0

The issue was my cups.conf file. Since I was mostly in office so the the cups server of office was configured I edited /etc/cups/client.conf file with

Servername localhost:631

and the printer appeared everywhere in the system.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .