I am a kali linux beginner, So after installing I was following a tutorial I needed to do sudo apt-get install scrcpy on the root user. I am getting error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package scrcpy

I also tried this link to solve my problem but no help. https://ftlinuxcourse.com/e-unable-to-locate-package-kali-linux-2020-problem-solved

What I am using: kali linux 4Virtual Box, i386 2020 Virtual box 6.1 KALI LINUX

Regards, Saad

  • I am also a beginner Jan 24, 2021 at 17:46
  • 3
    do not use Kali to learn Linux .... install a user friendly distribution, such as Mint or Ubuntu
    – jsotola
    Jan 24, 2021 at 18:01
  • I know some of the important commands Jan 25, 2021 at 4:15
  • the problem is that you do not know if you made a mistake, or if Kali is broken ... it would make sense to eliminate one trap from your learning
    – jsotola
    Jan 25, 2021 at 4:20
  • Sorry I understand I should start with Ubuntu or something simpler but I want to learn this for white hats and I have been told ubuntu is an OS by someone but I think it's like a part of linux Jan 25, 2021 at 4:24

1 Answer 1


The package is only available for debian Sid and Ubuntu 20.04 through apt.

You can install scrcpy on kali linux through snap:

sudo apt update
sudo apt install snapd
sudo snap install core
sudo systemctl unmask snapd
sudo systemctl enable --now snapd
sudo snap install scrcpy

add the following line to your ~/.zshrc:

echo "alias scrcpy='/snap/bin/scrcpy'" >> ~/.zshrc


source ~/.zshrc
  • I get this error and I also know we can download from snap but I then get the error error: cannot communicate with server: Post "http://localhost/v2/snaps/scrcpy": dial unix /run/snapd.socket: connect: no such file or directory Jan 25, 2021 at 4:17
  • so @GAD3R how can I run this like I tried just scrcpy it says no command like that but it works fine when I do snap run scrcpy. Just asking can I do with just scrcpy and what does that unmask mean I know systemctl is for systemd Jan 25, 2021 at 14:51
  • How do I cd into .zshrc and no worries I needed to just check Jan 25, 2021 at 17:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .