1

I am using on Fedora 32 a wireless usb mouse that get autosupended and that's driving me crazy. I looked online and tried many things without success.

I identified the device using powertop

   Good          Autosuspend for USB device xHCI Host Controller [usb1]
   Good          Autosuspend for USB device xHCI Host Controller [usb2]
   Good          Autosuspend for unknown USB device 1-7 (8087:0a2b)
   Good          Autosuspend for unknown USB device 1-9 (138a:0097)
   Good          Autosuspend for USB device USB3.0-CRW [Generic]                                                        
   Good          Autosuspend for USB device Integrated Camera [SunplusIT Inc]
>> Bad           Autosuspend for USB device 2.4G Wireless Receiver [Nordic]

I tried many things

  • tried to install tuned
  • added a file in /etc/modprobe.d by doing sudo echo "options usbcore autosuspend=-1" | sudo tee /etc/modprobe.d/disable-usb-autosuspend.conf > /dev/null
  • updated /etc/default/grub to GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora/root rd.luks.uuid=luks-113d6727-daed-4f2f-b1e7-5ejsudt456370 rd.lvm.lv=fedora/swap rhgb quiet usbcore.autosuspend=-1"

That did nothing I would like to selectively disable autosuspend for that mouse OR disable usb autosuspend on everything

2 Answers 2

0

I found a way by creating a crontab as root

@reboot echo 'on' > '/sys/bus/usb/devices/1-2/power/control';

that was what was given by powertop when I was toggling on/off

0

I was trying to do something similar (on Ubuntu instead of Fedora). Adding a file in /etc/modprobe.d also didn't work for me, but running sudo update-grub after updating /etc/default/grub did work for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .