0

I tried to install Void-Linux as secondary Linux on my laptop. I created a new partition for it on LVM, installed base system using XBPS method copied kernel and initramfs to my /boot partition and created /etc/fstab. It booted almost correctly but with one exception: the rootfs is readonly by default, so I need to remount it every time with mount -o remount,rw / after booting. I tried to add rw option to fstab explicetely but it didn't help:

# /etc/fstab
# <fs>                  <mountpoint>    <type>      <opts>                  <dump/pass>
/dev/SDD/void           /               ext4        rw,defaults,relatime    0 1
/dev/mapper/home        /home           ext4        defaults,noatime        0 0
/dev/mapper/var         /var            ext4        defaults,relatime       0 1
UUID=7720-4261          /boot           vfat        noatime,noauto          0 0
tmpfs                   /tmp            tmpfs       rw,nosuid,noatime,nodev,size=4G,mode=1777 0 0

# /boot/grub/grub.conf entry
    
    insmod gzio
    insmod part_gpt
    insmod fat
    set root='hd2,gpt2'
    echo    'Loading Void Linux 5.10.8_1 ...'
    linux   /vmlinuz-5.10.8_1 root=/dev/SDD/void dolvm 
    echo    'Loading initial ramdisk ...'
    initrd  /early_ucode.cpio /initramfs-5.10.8_1.img

I don't have a such problem with same configuration on other Linux systems, is it related to specific behavior of Void-Linux? How to make my rootfs read-write for that case?

0

I've fixed it by using rw kernel command line flag in grub config:

-     linux   /vmlinuz-5.10.8_1 root=/dev/SDD/void dolvm 
+     linux   /vmlinuz-5.10.8_1 root=/dev/SDD/void dolvm rw

/etc/fstab mount options seems to be not related to this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.