2

Im on Manjaro GNOME. I installed this package from AUR via Add/Remove Software: https://aur.archlinux.org/packages/github-desktop/

It told me that I need to restart as it /installed/reinstalled some kernel modules or something. Now my default gnome-terminal does not work. I cannot open it.

When I try to open it either via keyboard shortcut or an icon it tries to start but never shows up. I can see it as a process, it shows up for a second in my System Monitor and then just disappears

I installed another (Deepin) terminal. And when I open him that's what I get:

_p9k_init_params:72: character not in range                                                                   
manjaro% 

The same also happens with alacrity terminal.

THe GNOME terminal had ZSH and a lot of emojis etc

4

I have the same problem after a recent update. I am no expert but I guess something wrong with the locale settings. I fixed it by regenerating the locale settings as shown here:

Open a terminal with Ctrl + Alt + F3

In /etc/locale.gen add/uncomment

en_US.UTF-8 UTF-8

then run with sudo:

locale-gen

Then my gnome terminal is functional again.

0

Manjaro Gnome after installing updates and rebooting I could not open terminal and after installing deepin terminal I got the above message.

After searching on the web for answers this is what fixed it:

  1. Back up your .zshrc if its not already in the .zshrc.bak and delete the .zshrc file

  2. Install deepin terminal from your package manager

  3. after opening deepin terminal type:

    echo en_US.UTF-8 UTF-8 | sudo tee -a /etc/locale.gen
    

    Then:

    echo en_ZA.UTF-8 UTF-8 | sudo tee -a /etc/locale.gen
    

    Then:

    sudo locale-gen
    
  4. Reboot your PC

  5. After the reboot your terminal will open but it looks very much vanilla.

  6. Please check if you have a .zshrc file if not create one or just paste the one you backed up or copy the contents of .zshrc.bak into the new .zshrc file.

  7. source .zshrc

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.