0

I've been trying to fix this error for hours and so far just failed.

The following case I am trying to solve:

I have 2 application servers which are accessed by a third server. All servers are running an Apache2 installation. The third server acts as a load balancer using the Apache2 proxy module.

This is working fine so far except for: The application running on the two application servers offers the possibility to stream music (GET request). For songs that have a length of about 6-8 minutes, the loadbalancer always terminates the connection at about 05:36 (minutes) with the following error message: "nop_streaming_read error : Connection reset by peer" (MPlayer)".

My first suspicion was immediately "Timeout" or "Keep Alive" - but increasing this unfortunately did not solve the problem either.

If one of the two application servers is addressed directly, the stream runs through without problems.

Here is my Apache2 vHost configuration (load balancer)

<VirtualHost *:80>
        ServerName xxxx.at
        ServerAlias xxxx.at

        ServerAdmin xxxxx
        DocumentRoot /var/www/html


        ProxyRequests off

        <Proxy balancer://mycluster>

                # DEVONE1
                BalancerMember http://node1.xx.at:80 timeout=3600 retry=60

                # DEVONE2
                BalancerMember http://node2.xx.at:80 timeout=3600 retry=60

                ProxySet lbmethod=byrequests

        </Proxy>

#       <Location /balancer-manager>
#               SetHandler balancer-manager
#       </Location>

        SSLProxyEngine on
        ProxyTimeout 3600
        ProxyPass /balancer-manager !
        ProxyPass / balancer://mycluster/

        # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
        # error, crit, alert, emerg.
        # It is also possible to configure the loglevel for particular
        # modules, e.g.
        #LogLevel info ssl:warn

        ErrorLog ${APACHE_LOG_DIR}/error_live.log
        CustomLog ${APACHE_LOG_DIR}/access_live.log combined

        # For most configuration files from conf-available/, which are
        # enabled or disabled at a global level, it is possible to
        # include a line for only one particular virtual host. For example the
        # following line enables the CGI configuration for this host only
        # after it has been globally disabled with "a2disconf".
        #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

Unfortunately, the error.log does not contain a suitable error message. I am glad about every answer!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.