I run Debian 10/Gnome on a Lenovo Y2P, so far without problem. In particular uname -a yields:

Linux deepthought 4.19.0-13-amd64 #1 SMP Debian 4.19.160-2 (2020-11-28) x86_64 GNU/Linux

Since I once ran sudo halt on 4.19.0-11-amd64, synclient -l yields:

Couldn't find synaptics properties. No synaptics driver loaded?

I.e. the touchpad works, but less sensitive, no 2-FingerScroll, no click-drag, and the Mouse & Touchpad settings menu is reduced to a basic form. On the previous version, 4.19.0-10-amd64 the touchpad still works completely normal.

Here is, what I tried so far:

  1. I have xserver-xorg-input-libinput and xserver-xorg-input-synaptics installed (and re-installed, to no avail).

  2. As in this StackExchange answer, xinput list yields:

↳ PS/2 Synaptics TouchPad id=13 [slave pointer (2)]

but copying the synaptics config file, as suggested:

cp /usr/share/X11/xorg.conf.d/70-synaptics.conf /etc/X11/xorg.conf.d/70-synaptics.conf

and rebooting did not solve the problem. The content of 70-synaptics.conf is:

# Example xorg.conf.d snippet that assigns the touchpad driver
# to all touchpads. See xorg.conf.d(5) for more information on
# InputClass.
# DO NOT EDIT THIS FILE, your distribution will likely overwrite
# it when updating. Copy (and rename) this file into
# /etc/X11/xorg.conf.d first.
# Additional options may be added in the form of
#   Option "OptionName" "value"
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
#       MatchDevicePath "/dev/input/event*"

Section "InputClass"
        Identifier "touchpad ignore duplicates"
        MatchIsTouchpad "on"
        MatchOS "Linux"
        MatchDevicePath "/dev/input/mouse*"
        Option "Ignore" "on"

# This option enables the bottom right corner to be a right button on clickpads
# and the right and middle top areas to be right / middle buttons on clickpads
# with a top button area.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Default clickpad buttons"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
        Option "SecondarySoftButtonAreas" "58% 0 0 15% 42% 58% 0 15%"

# This option disables software buttons on Apple touchpads.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Disable clickpad buttons on Apple touchpads"
        MatchProduct "Apple|bcm5974"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "0 0 0 0 0 0 0 0"
  1. Re-adding the module to the kernel did not help but tells me this: insmod /lib/modules/4.19.0-13-amd64/kernel/drivers/input/mouse/psmouse.ko proto=imps

  2. Following this reddit, i checked dmesg like so:

$ sudo dmesg | grep -i PS/2
[    1.799257] i8042: PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
[    1.812958] mousedev: PS/2 mouse device common for all mice
[    2.218457] input: PS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input5
[  246.027504] input: PS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input81

However, my xorg log contains nothing about Synaptics:

[   189.259] 
X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
[   189.259] Build Operating System: Linux 4.9.0-8-amd64 x86_64 Debian
[   189.259] Current Operating System: Linux deepthought 4.19.0-10-amd64 #1 SMP Debian 4.19.132-1 (2020-07-24) x86_64
[   189.259] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.19.0-10-amd64 root=UUID=48c75b27-4eb3-426f-9a8b-80bac1fc66d5 ro quiet
[   189.259] Build Date: 05 March 2019  08:11:12PM
[   189.259] xorg-server 2:1.20.4-1 (https://www.debian.org/support) 
[   189.259] Current version of pixman: 0.36.0
[   189.259]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[   189.259] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   189.260] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Aug  6 14:41:07 2020
[   189.260] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   189.260] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   189.261] Parse error on line 3 of section Device in file /etc/X11/xorg.conf.d/20-displaylink.conf
        "MatchDriver" is not a valid keyword in this section.
[   189.262] (EE) Problem parsing the config file
[   189.262] (EE) Error parsing the config file
[   189.262] (EE) 
Fatal server error:
[   189.262] (EE) no screens found(EE) 
[   189.262] (EE) 
Please consult the The X.Org Foundation support 
         at http://wiki.x.org
 for help. 
[   189.262] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   189.262] (EE) 
[   189.262] (EE) Server terminated with error (1). Closing log file.

The error in here stems from another halted project - it has not influenced the synaptics driver in the past. But I don't see anything about the latter.

(side question: i removed the file 20-displaylink.conf a while ago, i.e. this file doesn't exist anymore. when/how does this log get updated?)

  1. As I expected, adding the module automatically at start up, as suggested here did not change anything.

  2. This link tells me, that Gnome 3.20 no longer supports synaptic drivers, but switched to libinput. I have 3.30.2., so while the behavior would make sense, I have the same Gnome version on the Kernel version 4.19.0-10-amd64, and it works just fine. Anyhow, this wiki entry should then tell me how to switch to libinput - but i seem to be too stupehd for that, i.e. I don't get what I need to do.

Now, slowly desperation kicks in, as I am not (yet) familiar enough with Linux, to cook up my own solution. Hence, any help is greatly appreciated. Also: how could halt mess this up? Is there some danger to it, I should know about?

Thank you big time!

1 Answer 1


To anyone encountering the same problem in the future: I resolved this issue by reinstalling the OS. Sorry I don't have better news.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .