7

I have recently installed arch linux along with gnome DE. During installation I used iwctl command to connect to wifi. But after installing the DE, I no longer need it.

But on every boot, it automatically connects to wifi network, and hence I am not able to use the gnome settings to connect to wifi. I have to open terminal and open iwctl and then use the disconnect command station wlan0 disconnect. After this only I am able to switch networks from the gnome settings.

How do I stop iwctl from connecting to the network everytime on a boot? Should I disable iwd service, since iwctl comes under that? Or would that cause more trouble.

Link to iwd page on archwiki.

2 Answers 2

8

You might want to use the command known-networks <Network-Name> set-property AutoConnect no from within iwctl.

1
  • 1
    You can also add AutoConnect=false under a [Settings] category in /var/lib/iwd/<network name>.psk if you prefer that option.
    – Torxed
    Commented Mar 11 at 6:40
6

I was able to forget the network from iwctl.

Just run run iwctl

and then run known-networks list, to list the known networks to iwctl. And then use known-networks SSID forget where SSID is the SSID is the SSID of a network you are trying to forget

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .