5
simon@simon-XPS-15-9500:~$ sudo lshw -C network
[sudo] password for simon: 
  *-network UNCLAIMED       
       description: Network controller
       product: Qualcomm
       vendor: Qualcomm
       physical id: 0
       bus info: pci@0000:6c:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:b4200000-b42fffff
  *-network
       description: Ethernet interface
       physical id: 3
       bus info: usb@4:2.4
       logical name: enx00e04c7863f8
       serial: 00:e0:4c:78:63:f8
       size: 1Gbit/s
       capacity: 1Gbit/s
       capabilities: ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8152 driverversion=v1.11.11 duplex=full firmware=rtl8153a-4 v2 02/07/20 ip=10.0.0.2 link=yes multicast=yes port=MII speed=1Gbit/s
simon@simon-XPS-15-9500:~$ lspci -knn | grep Net -A3; rfkill list
6c:00.0 Network controller [0280]: Qualcomm Device [17cb:1101] (rev 01)
    Subsystem: Bigfoot Networks, Inc. Device [1a56:a501]
6d:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5260 PCI Express Card Reader [10ec:5260] (rev 01)
    Subsystem: Dell RTS5260 PCI Express Card Reader [1028:097d]
    Kernel driver in use: rtsx_pci
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
simon@simon-XPS-15-9500:~$ uname -r
5.8.0-38-generic

I'm having issues with trying to get the wifi adapter to work in this laptop. I've tried installing backport-iwlwifi and also updating kernel version to 5.10 (had to reset back to 5.8) but no luck, also seems like all solutions for Qualcom Atheros don't work either.

How to get ath11k driver working on Ubuntu?

2
1

You need to compile a custom kernel with ath11k support.

How to in wireless.wiki.kernel.org: Installing ath11k

As of this writing (December 2020) Linux distributions do not support QCA6390 PCI devices out of box, so you need to install kernel and firmware manually. Here are simple instructions how to install Linux kernel v5.10 with ath11k PCI support and latest ath11k firmwares.

3
  • Hello @GAD3R, following the guide I can only see atheros ath10k support when I run make menuconfig
    – Simon
    Jan 23 at 11:27
  • @Simon with the 5.10 kernel?
    – GAD3R
    Jan 23 at 11:33
  • 1
    yes, step by step as shown on guide with 5.10 kernel
    – Simon
    Jan 28 at 13:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.