6

Minimize, Maximize, Close icons are missing in my GNOME desktop of Kali Linux. However, when I click in the place they are supposed to be, they do what they are supposed to do.

This is what all my windows look like.

Weirdly, Firefox is only missing the maximize icon!

This may have been caused when I tried to install xserver-xorg-input-synaptics. This apparently removed kali-desktop-gnome but I could use gnome even after running the installing synaptics. Anyway, I installed kali-desktop-gnome again (which automatically removed xserver-xorg-input-synaptics but the issue is still here.

PS: I would also like to know if it is possible to install xserver-xorg-input-synaptics without removing gnome because I want to enable my touchpad tap to click (synclient tapbutton1=1) in xfce too.

Edit: Minimize and Maximize options are already enabled in Gnome Tweaks. Added as per requested by @iaeiou.

7 Answers 7

3

gsettings set org.gnome.desktop.wm.preferences button-layout ":minimize,maximize,close"

more from this thread

2
  • Welcome to Unix&Linux SE, Mathias! Do you mean that there is a typo in Santiago Echevarria's answer? If so, it would be great to suggest an edit to that answer, so that we have it right. See: How does editing work? Jun 25, 2021 at 8:06
  • Don't mind me, I didn't look around well enough before posting my answer. I can edit it anyway, the upvotes must have come from the link not necessarily the answer I posted. And besides Mathias is new to the world of Stacks! Jun 26, 2021 at 11:41
2
+50

Had same problem on arch. Simply reinstalled gnome-shell and updated.

1
  • 1
    for confused peeps coming here with xfce instead of gnome, try running xfwm4 Nov 2, 2022 at 3:50
2

Try out this gsettings command and see if it restarts the buttons

gsettings set org.gnome.desktop.wm.preferences button.layout ":minimize,maximize,close"
0
1

try this: rm -rf ~/.cache/sessions

2
  • 4
    Could you possibly explain why this would help and what the issue is that this particular solution solves that none of the other solves?
    – Kusalananda
    Apr 10, 2022 at 18:30
  • this one totally worked for me, I'm using in VirtualBox and I had to add the machine from a previous state
    – Y4RD13
    Oct 11, 2023 at 4:34
-1

Open a terminal and enter xfwm4& The command restarts the windows manager and backgrounds the process

1
  • Please edit your answer and describe what this command is and how it will help.
    – Scottie H
    Jul 18, 2022 at 19:49
-2

Open a terminal and enter

xfwm4

then press enter. This should restart your window manager and recover your buttons

1
  • This would work in XFCE, not GNOME. Nov 16, 2021 at 9:31
-3

I was having the same problem: minimize/maximize/close buttons disappear like the screenshot above.

The temporary solution that I got was the command xfwm4. It solves the problem temporarily but when I reboot, the problem still occurs so the permanent solution to Xfce Desktop is not yet discovered I think ...

So I installed GNOME Desktop. It works well you don't lose any files and it is very attractive so don't waste your time trying to solve the Xfce Desktop problem permanently - let it go and start using GNOME.

1
  • The posted question asks for help with issues in GNOME, not XFCE. They can't switch to GNOME because they are already using GNOME desktop. Nov 16, 2021 at 9:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .