My machine is running RHEL 5 x86_64 I'm facing a problem with oh-my-zsh

The zsh version on my machine is

zsh --version
zsh 4.2.6 (x86_64-redhat-linux-gnu)

There are no upgrades available via yum. How can I install a newer version of zsh?

I've tried to look for rpms on the internet but they're for fedora or other distros.

➜  src  sudo rpm -ivh zsh-5.0.2-1.fc18.x86_64.rpm  
warning: zsh-5.0.2-1.fc18.x86_64.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID de7f38bd
error: Failed dependencies:
    libc.so.6(GLIBC_2.11)(64bit) is needed by zsh-5.0.2-1.fc18.x86_64
    libc.so.6(GLIBC_2.14)(64bit) is needed by zsh-5.0.2-1.fc18.x86_64
    libc.so.6(GLIBC_2.15)(64bit) is needed by zsh-5.0.2-1.fc18.x86_64
    libc.so.6(GLIBC_2.7)(64bit) is needed by zsh-5.0.2-1.fc18.x86_64
    libtinfo.so.5()(64bit) is needed by zsh-5.0.2-1.fc18.x86_64
    rpmlib(FileDigests) <= 4.6.0-1 is needed by zsh-5.0.2-1.fc18.x86_64
    rpmlib(PayloadIsXz) <= 5.2-1 is needed by zsh-5.0.2-1.fc18.x86_64
➜  src  sudo rpm -ivh zsh-4.3.17-1.fu2012.x86_64.rpm 
warning: zsh-4.3.17-1.fu2012.x86_64.rpm: Header V4 DSA signature: NOKEY, key ID 42d68235
error: Failed dependencies:
    libc.so.6(GLIBC_2.11)(64bit) is needed by zsh-4.3.17-1.fu2012.x86_64
    libc.so.6(GLIBC_2.14)(64bit) is needed by zsh-4.3.17-1.fu2012.x86_64
    libc.so.6(GLIBC_2.15)(64bit) is needed by zsh-4.3.17-1.fu2012.x86_64
    libc.so.6(GLIBC_2.7)(64bit) is needed by zsh-4.3.17-1.fu2012.x86_64
    libgdbm.so.3()(64bit) is needed by zsh-4.3.17-1.fu2012.x86_64
    libtinfo.so.5()(64bit) is needed by zsh-4.3.17-1.fu2012.x86_64
    rpmlib(FileDigests) <= 4.6.0-1 is needed by zsh-4.3.17-1.fu2012.x86_64
    rpmlib(PayloadIsXz) <= 5.2-1 is needed by zsh-4.3.17-1.fu2012.x86_64

It appears that I can't install the latest version of glibc either :|


In the comment on github, someone says they used the zsh 4.3.10 from CentOS. I did the same, using the src.rpm from CentOS 6. The RPM built fine with no modifications needed. Here's the RPMs, the source, debuginfo, and html RPMs are in the same directory if you need them:

I built the RPM using mock.

  • I'm using ZSH version 5.0.2. The minimum required version for Powerlevel10k is 5.1. I can't find a updated package? do you have a reference to >5.1rpm package? I tried to install rpm -U zsh-5.5.1-6.el8_1.2.x86_64.rpm from, but It's giving error warning: zsh-5.5.1-6.el8_1.2.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 8483c65d: NOKEY error: Failed dependencies: libgdbm.so.6()(64bit) is needed by libm.so.6(GLIBC_2.23)(64bit) libncursesw.so.6()(64bit) libtinfo.so.6()(64bit) – Anu Aug 7 '20 at 2:15

If you really must run a newer version of zsh, I'd start with the source RPM for RHEL 5 (o even RHEL 6), unpack it, replace the source in it by the latest, and build your own. Fedora has instrucions, which should be mostly applicable to RHEL, which descends from Fedora.

Just be sure to check that the patches still apply, perhaps look for the latest Fedora source RPM and create your RHEL rpm by stitching its sources and patches in.

Note that you are taking over the responsibility to keep your package up to date and secured.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.