1

So i decided to use freebsd as my daily driver but the xorg seems not to work so first of all when i tried startx for the first time (i installed the nvidia drivers) it gave

(EE) Cannot run in framebuffer mode. Please specify busIDs for all framebuffer mode

Heres the full log file - https://pastebin.com/sKCsm2Nn

Then i tried nvidia-xconfig then it gave me this-

(EE) no screens found(EE)

Heres the full log - https://pastebin.com/5kXndP8J I have a lenovo flex 2-14 heres my gpu specifications-

vgapci0@pci0:0:2:0: class=0x030000 card=0x397817aa chip=0x0a168086 rev=0x0b hdr=0x00 vendor = 'Intel Corporation' device = 'Haswell-ULT Integrated Graphics Controller' class = display -- vgapci1@pci0:4:0:0: class=0x030200 card=0x381717aa chip=0x114010de rev=0xa1 hdr=0x00 vendor = 'NVIDIA Corporation' device = 'GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M]' class = display

I have installed the nvidia-driver-390-390.138_1, drm-kmod(i915kms.ko).

6
  • 1
    You are required to post your minimal, relevant information here and not a link to other sites like pastebin. How to Ask – Rob Jan 13 at 10:12
  • 1
    How did you install xorg and nvidia? Did you use pkg? Did you make any changes to Xorg.conf? What is in .xinitrc? I think you no longer need to run nvidia-xconfig as FreeBSD auto detects it but I could be wrong. – Rob Jan 13 at 10:15
  • As ive said earlier without the xorg.conf it give me (EE) Cannot run in framebuffer mode. Please specify busIDs for all framebuffer mode – sierra Jan 14 at 4:40
  • meh i switched to nomadbsd instead – sierra Jan 14 at 6:56
  • 1
    Well, nomad bsd is pre-configured FreeBSD. – Rob Jan 14 at 12:46
0

I assume you are using 12.2-RELEASE . There's a lot of checklist to ask .

  • drm-kmod is broken https://twitter.com/vermaden/status/1321375859429773312 , you need to build it from port
  • you need to add user to video group by # pw group mod video -m your_username
  • there's also option to switch 12.1-RELEASE , or CURRENT
  • adding # sysrc kld_list+="/boot/modules/i915kms.ko"
  • ofc , after installing nvidia-driver properly use kldload nvidia-modeset then reboot

Hope either one of these help

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.