0

I recently tried to install a large program and inadvertently filled up my Linux partition. I am now seeing a bunch of errors stemming from this issue. I tried to empty the trash, but I get an error whenever I do so. I've also done rm on several big files, but my OS still seems to think its partition is full, and I'm still seeing the same errors.

How can I free up some memory so my system starts behaving normally again?

I'm operating with Linux Mint 18.2.

Edit: Some specific errors are as follows:

  • When I try to tab-complete in a terminal, I get
      bash: cannot create temp file for here-document: No space left on device
    
  • When I try to manually delete files from the trash folder (via a file browser), I get an alert saying
    Error while deleting.  There was an error deleting <filename>.
    
  • When I click the "Empty Trash" button from the file browser, nothing happens. The files in the Trash are unaffected.
5
  • Try to include some of the errors. That actually tells us what is going on and how it can be fixed. Actual errors are a lot more useful than "a bunch of errors", "I get an error", ... Jan 13, 2021 at 3:27
  • @EduardoTrápani I've added some examples. I'll try to identify some more. The first one makes it very clear that the system thinks it is out of memory.
    – Yly
    Jan 13, 2021 at 3:48
  • Have you rebooted? That would clear up RAM and /tmp.
    – bitinerant
    Jan 13, 2021 at 4:17
  • You should be able to cd into the folder where the Trash is and rm them. Jan 13, 2021 at 4:17
  • 1) Execute df -h and check output. 2) Files could be removed, but inodes are opened. You can use command lsof to check whether files that were removed still exist.
    – metallic
    Jan 13, 2021 at 18:47

1 Answer 1

0

Rebooting fixed the issue. I was worried that if the bootloader needed some disk space I might not be able to reboot, so I was saving this as a last resort. However, it worked. Note that this was after deleting some files manually via rm.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .