0

At boot time I want to start the Pidgin Instant Messenger on a system running Bodhi Linux 5.1.0.

On boot, the user is automatically logged in.

It works fine when I start it manually from the GUI.

When I hit /usr/bin/pidgin from a terminal window, it also starts.

With nano I created and saved:

sudo nano /etc/systemd/system/pidgin.service

Contents:

Description=Pidgin Instant Messenger

Wants=network.target
After=syslog.target network-online.target

[Service]
Type=simple
ExecStart=/usr/bin/pidgin
Restart=on-failure
RestartSec=10
KillMode=process

[Install]
WantedBy=multi-user.target

I reloaded all services, enabled, and started the service:

sudo systemctl daemon-reload
sudo systemctl enable pidgin
sudo systemctl start pidgin

This shows it as enabled:

sudo systemctl list-unit-files --type=service

But...:

sudo systemctl status pidgin.service

...shows in red:

Process: 3915 ExecStart=/usr/bin/pidgin (code=exited, status=1/FAILURE)
Main PID: 3915 (code=exited, status=1/FAILURE)

What did I wrong?

0

After some digging through the menus, I found the solution there - no fiddling in terminal mode necessary.

FWIW, for those who use Bodhi Linux with the Moksha desktop:

Menu, Settings, Settings Panel
Apps, Startup Applications, Applications
CLICK Pidgin Internet Messenger
+ Add
Apply, Close
CLOSE Settings Panel

Restart the PC to test if it works.

Obviously, any other GUI application can be started this way when the system (re)boots.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.