I am using Logitech Trackball Marble and I have difficulty adjusting the sensitivity of it in Linux Mint 13.

Apparently the sensitivity and acceleration setting in Linux Mint only work for the mouse. ( I have both mouse and trackball plugged)

How can I adjust it? I searched about it in google but find no useful result. I've seen people digging in something called xorf.conf but I have no idea what it is. I check my /etc/X11 directory and found no xorf.conf but only some file looks like xorf.conf.fail


It's likely that the graphical settings interface simply can't support more than one pointing device. Therefore, you may need to add the device and adjust its settings in xorg.conf. Check out the documentation on how to do that here:


Once you've defined the device, it looks like you can use xorg.conf's "Sensitivity" option to adjust it, or use xinput:


They don't specifically go into it on that answer, but man xinput shows that [DEVICE] can be one of the primary arguments to xinput.


In your question, you say you have both a mouse and trackball plugged in. In your bounty comment, you say you need a solution because you only use a trackball. If you unplug the mouse and only plug in the trackball, then Mint's graphical Mouse configuration in the Settings panel should work just fine to configure the trackball sensitivity. (Where it gets tricky is defining what your trackball buttons do-- emulating scrollwheel and middle click behavior, if necessary, but that's not what you asked about...)

  • It only applies to Ubuntu and I am using Linux Mint. The configuration and environment setting is different. There is no guarantee of success. It could screw up my keyboard configuration. – lamwaiman1988 Feb 11 '13 at 12:53
  • Linux Mint is a derivative of Ubuntu, so most directions for Ubuntu work for Mint, unless they are Unity-specific. (I say this as a user of both Ubuntu and Mint.) xinput changes the X configuration, which does apply to Mint. – Alison R. Feb 11 '13 at 16:05
  • First there is no 50-marblemouse.conf in the xorg.conf.d directory of my Mint 13 xfce. Secondly, the sensitivity doesn't work for trackball even if I unplugged the mouse. – lamwaiman1988 Feb 18 '13 at 9:16
  • 50-marblemouse.conf will not exist until you create it. – Alison R. Feb 20 '13 at 16:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.