1

My laptop does not suspend when I close the lid. I have the default settings in /etc/systemd/logind.conf, i.e. everything is commented out (uncommenting does not have an effect, as expected):

$ grep -i lid /etc/systemd/logind.conf
> #HandleLidSwitch=suspend
> #HandleLidSwitchExternalPower=suspend
> #HandleLidSwitchDocked=ignore
> #LidSwitchIgnoreInhibited=yes

Suspicious to me is, that when I look at journalctl, and close the lid, I do not see any event message.

Suspending from the command line works just fine.

How can I suspend my laptop when the lid is closed?

Edit: I am on Arch Linux with i3.

$ systemd-inhibit --list
> WHO            UID USER PID COMM           WHAT  WHY                                       MODE 
> NetworkManager 0   root 314 NetworkManager sleep NetworkManager needs to turn off networks delay
> 
> 1 inhibitors listed.

Edit2: I checked the state of the lid like this:

while true; do
    cat /proc/acpi/button/lid/LID0/state
    sleep 1
done

Then closed the lid for a while, opened it again. I always got the same output:

state:     open

Edit 3:

$ dmesg | grep -i lid
> [    1.131805] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input0
> [    1.131837] ACPI: Lid Switch [LID0]

2 Answers 2

2

HandleLidSwitch can take one of these parameters :

suspend 
lock 
ignore
poweroff

You need to restart logind service so the changes take effect :

systemctl restart systemd-logind.service
9
  • No, I tried that, it doesn't work. Thanks for the help anyway. (I did not downvote you.)
    – pfnuesel
    Commented Jan 7, 2021 at 10:45
  • Yes i've seen the downvote; Which distro you are in ?
    – Reda Salih
    Commented Jan 7, 2021 at 11:11
  • Try setting all this values : HandleHibernateKey=suspend HandleSuspendKey=suspend HandleLidSwitch=suspend HandleLidSwitchDocked=suspend
    – Reda Salih
    Commented Jan 7, 2021 at 11:13
  • Arch Linux. I set everything that remotely makes sense to suspend. Restarted the service. Closed the lid for several minutes. Nothing.
    – pfnuesel
    Commented Jan 7, 2021 at 11:24
  • Could you add the output of systemd-inhibit --list. Also are you using Gnome ?
    – Reda Salih
    Commented Jan 7, 2021 at 11:37
0

On my Latitude 5491 I can force close lid action in BIOS, therefore also check your BIOS settings.

1
  • Thanks. I checked every setting my BIOS carefully, but there is nothing related to closing the lid.
    – pfnuesel
    Commented Jan 7, 2021 at 12:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .