0

I have and "aesthetic" problem regarding my Hyper terminal. When I start it, (probably) something happens in the ~/.zshrc file and it prints and ugly empty line with a % in the terminal.enter image description here

I am not sure if this problem actually comes from the ~/.zshrc file, however, here is the conda initialise section of my ~/.zshrc file.

I would like to get rid of this % getting printed every time I open my terminal.

# >>> conda initialize >>>
# !! Contents within this block are managed by 'conda init' !!
    __conda_setup="$('/usr/local/Caskroom/miniconda/base/bin/conda' 'shell.zsh' 'hook' 2>                /dev/null)"
if [ $? -eq 0 ]; then
    eval "$__conda_setup"
else
    if [ -f "/usr/local/Caskroom/miniconda/base/etc/profile.d/conda.sh" ]; then
        . "/usr/local/Caskroom/miniconda/base/etc/profile.d/conda.sh"
    else
        export PATH="/usr/local/Caskroom/miniconda/base/bin:$PATH"
    fi
fi
unset __conda_setup
# <<< conda initialize <<<

1 Answer 1

0

Finally, after playing around, I found out that the error happens when the window is too small. Tried to resize it and made it wider solved the issue.

Sometimes the most simple things are the exact solution.

2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .