2

I just bought a new laptop (Asus UX435EG-AI084R) equipped with an Intel Tiger Lake CPU (i7-1165G7; 2.80GHz) and I installed Debian Linux (Testing) on it. Unfortunately I am experiencing a very strange issue related to CPU frequency scaling. Every time the CPU is under heavy load, the frequency goes down to 400MHz. The moment the CPU stops being under load and the system is (almost) idle, the frequency goes up to ~1.2GHz. The CPU never runs hot. The system, for some reason, instead of increasing the frequency when needed, it decreases it! Interestingly, this behaviour is not present under Windows 10 Pro (dual boot).

I have tried the following without managing to change the above strange behaviour:

  • I disabled the intel_pstate (intel_pstate=disable kernel parameter)
  • Forced the 'performance' policy instead of 'powersave'
  • Set the minimum frequency to 3GHz. Yes, even that doesn't work! The CPU will still go down to 400MHz at full load and will return to 3GHz on idle.
  • I tried to uninstall tlp.
  • I double-checked the temperature. It never goes above 60C under load.
  • I tried every single possible solution I found online and nothing works.
  • I disabled Turbo Boost
  • There are no CPU-related options in the BIOS to fiddle.
  • Disconnecting the laptop from the charger didn't make any difference.

Since the problem only appears on Linux, I started to suspect that this is a kernel/firmware/driver bug. So what I did was to live boot Intel Clear Linux and do the following:

  • Run four simple while True: pass Python scripts in order to occupy all 4 cores; lscpu returned ~400MHz.
  • Kill one of the running scripts to occupy 3 cores; lscpu returned ~800MHz.
  • Kill one of the running scripts to occupy 2 cores; lscpu returned ~1200MHz.
  • Kill one of the running scripts to occupy 1 cores; lscpu returned ~1800MHz.

Currently, Debian Linux (Testing) uses kernel 5.9.0-5, while Intel Clear Linux uses 5.9.12. My other laptop, with a 3-year-old Intel CPU and the same Debian Linux version, does not have this problem.

  • Is it reasonable to assume that we are looking at a software/kernel/driver bug?
  • While waiting for kernel 5.10 to land on Debian Testing, is there a way to completely disable any kind of frequency scaling?

Thank you

EDIT 1:

Turns out the 5.10 kernel did not fix anything. The same problem exists on Ubuntu 20.10. I guess I need to figure out what Intel Clear Linux does differently and try to configure Debian accordingly. Any advice is more than welcome.

2
0

Turns out I had to install thermald from the Debian repository. Once I did, everything started to work just fine. No more throttling down to 400MHz. Interestingly, I never had to install this package myself in the past and all my past laptops never had this issue. I guess it used to be installed automatically as a dependency of some other package but I never noticed it.

Thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.