6

I have downloaded expect5.4 . I'm trying to cross compile it for ARM(PandaBoard) running stripped down version of linux.

In the initial setup of configuring , I try

Shell$ ./configure --host=ARM
configure: WARNING: If you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used.
checking for correct TEA configuration... ok (TEA 3.9)
configure: configuring expect 5.45
checking for Tcl configuration... found /home/user1/scripts/tcl8.6.0/unix/tclConfig.sh
checking for existence of /home/user1/scripts/tcl8.6.0/unix/tclConfig.sh... loading
configure: --prefix defaulting to TCL_PREFIX /usr/local
configure: --exec-prefix defaulting to TCL_EXEC_PREFIX /usr/local
checking for ARM-gcc... /home/user1/toolchain/toolchain/arm-none-linux-gnueabi/bin/arm-none-linux-gnueabi-gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... yes
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether /home/user1/toolchain/toolchain/arm-none-linux-gnueabi/bin/arm-none-linux-gnueabi-gcc accepts -g... yes
checking for /home/user1/toolchain/toolchain/arm-none-linux-gnueabi/bin/arm-none-linux-gnueabi-gcc option to accept ANSI C... none needed
checking how to run the C preprocessor... /home/user1/toolchain/toolchain/arm-none-linux-gnueabi/bin/arm-none-linux-gnueabi-gcc -E
checking for a BSD-compatible install... /usr/bin/install -c
checking whether make sets $(MAKE)... yes
checking for ARM-ranlib... no
checking for ranlib... ranlib
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
..
..
..
..
..
checking for openpty... no
checking for openpty in -lutil... yes
checking if running Sequent running SVR4... no
checking build system type... i686-pc-linux-gnu
checking host system type... Invalid configuration `ARM': machine `ARM' not recognized
configure: error: /bin/bash tclconfig/config.sub ARM failed

Its able to pick arm-gcc but it fails for some reason.

UPDATE: On compiling with ./configure --host=arm, it goes further, and the error I'm now getting is:

checking for sysconf... yes
checking for strftime... yes
checking for strchr... yes
checking for timezone... yes
checking for siglongjmp... yes
checking for memcpy... yes
checking if WNOHANG requires _POSIX_SOURCE... configure: error: Expect can't be cross compiled

2 Answers 2

1

Try with

./configure --host=arm-linux
6
  • Thanks.On trying with --host=arm or --host=arm-linux, It goes further and now i get new error.(updated the question)
    – m4n07
    Jan 28, 2013 at 4:40
  • I just tried on my computer with --host=arm-linux and it finished with no errors, make showed a bunch of warnings for uninitialized variables, but generated a bunch of .o files as well as an expect executable.
    – lmcanavals
    Jan 28, 2013 at 6:08
  • I'm on Arch Linux x86_64 on an intel core i7 second gen. and besides not having tk on my system, just tcl, I can't think of anything special on my system.
    – lmcanavals
    Jan 28, 2013 at 6:14
  • Oh great!Whats the arm toolchain you are using for building ? Whats the arm compiler you are using, whats the version.
    – m4n07
    Jan 28, 2013 at 8:24
  • I'm on ubuntu on intel core i5 but using a different toolchain to build. ( svn.eaton.com/toolkit-docs )
    – m4n07
    Jan 28, 2013 at 8:33
0

Cross Compiling libavg for ARM: libavg-1.7.0 I use the following commands :

  1. sudo /usr/share/pdebuild-cross/xapt -a armel libpango1.0-dev libavformat-dev \
    libavcodec-dev libswscale-dev python2.6-dev libboost-python-dev libboost-thread-dev \
    libglu-dev libgl1-mesa-dev libgtk2.0-dev libglib2.0-dev libsdl-dev libxml2-dev \
    libxxf86vm-dev libcairo-dev librsvg2-dev –force-yes
    

    2.

    cat configure | sed s/-msse2// > configure.arm  
    mv configure.arm configure  
    chmod 755 configure
    
  2. Edit src/base/Exception.cpp and replace debugBreak code by :

    void debugBreak() {  
        #ifndef __arm__  
        #ifdef _WIN32  
        __asm int 3;  
        #else  
        asm(“int $3″);  
        #endif  
        #else  
        asm(“swi 0×03″);  
        #endif  
    }
    
  3. Exported these

    export PANGOFT2_CFLAGS=”-I/usr/arm-linux-gnueabi/include/”  
    export PANGOFT2_LIBS=”-L/usr/arm-linux-gnueabi/lib/”  
    export GDK_PIXBUF_CFLAGS=”-I/usr/arm-linux-gnueabi/include/”  
    export GDK_PIXBUF_LIBS=”-L/usr/arm-linux-gnueabi/lib/”  
    export LIBRSVG_CFLAGS=”-I/usr/arm-linux-gnueabi/include/”  
    export LIBRSVG_LIBS=”-L/usr/arm-linux-gnueabi/lib/”  
    export FONTCONFIG_CFLAGS=”-I/usr/arm-linux-gnueabi/include/”  
    export FONTCONFIG_LIBS=”-L/usr/arm-linux-gnueabi/lib/”  
    export FFMPEG_CFLAGS=”-I/usr/arm-linux-gnueabi/include/”  
    export FFMPEG_LIBS=”-L/usr/arm-linux-gnueabi/lib/”  
    

5-

CFLAGS=”-I/usr/arm-linux-gnueabi/include/gtk-2.0 -I/usr/arm-linux-gnueabi/include/glib-2.0″ CXXFLAGS=”-I/usr/arm-linux-gnueabi/include/gtk-2.0 -I/usr/arm-linux-gnueabi/include/glib-2.0/ -I/usr/arm-linux-gnueabi/lib/glib-2.0/include/ -I/usr/arm-linux-gnueabi/include/pango-1.0 -I/usr/arm-linux-gnueabi/include/cairo/ -I/usr/arm-linux-gnueabi/include/librsvg-2″ LDFLAGS=”-lgdk_pixbuf-2.0 -lavcodec -lavutil -lavformat -lswscale -lSDL -lpango-1.0 -lpangoft2-1.0 -lrsvg-2″ ./configure –target=arm-linux-gnueabi –host=arm-linux-gnueabi –with-sdl-prefix=/usr/arm-linux-gnueabi –prefix=/home/andree/CodeSourcery/Sourcery_G++_Lite/lib

and get this error:

configure: WARNING: if you wanted to set the –build type, don’t use –host. If a cross compiler is detected then cross compile mode will be used checking build system type… i686-pc-linux-gnu checking host system type… arm-none-linux-gnueabi checking target system type… arm-unknown-linux-gnueabi checking for arm-none-linux-gnueabi-gcc… arm-none-linux-gnueabi-gcc checking whether the C compiler works… no configure: error: in /home/andree/Bureau/libavg-1.7.1′: configure: error: C compiler cannot create executables Seeconfig.log’ for more details. the config.log file :

This file contains any messages produced by compilers while running configure, to aid debugging if configure makes a mistake.

It was created by libavg configure 1.7.1, which was generated by GNU Autoconf 2.67. Invocation command line was

$ ./configure –target=arm-linux-gnueabi –host=arm-none-linux-gnueabi –with-sdl-prefix=/usr/arm-linux-gnueabi –prefix=/home/andree/CodeSourcery/Sourcery_G++_Lite/lib

Platform.

hostname = andree-laptop
uname -m = i686
uname -r = 2.6.32-38-generic
uname -s = Linux
uname -v = #83-Ubuntu SMP Wed Jan 4 11:13:04 UTC 2012

/usr/bin/uname -p = unknown
/bin/uname -X = unknown

/bin/arch = unknown
/usr/bin/arch -k = unknown
/usr/convex/getsysinfo = unknown
/usr/bin/hostinfo = unknown
/bin/machine = unknown
/usr/bin/oslevel = unknown
/bin/universe = unknown

PATH: /home/andree/CodeSourcery/Sourcery_G++_Lite/bin
PATH: /usr/local/sbin
PATH: /usr/local/bin
PATH: /usr/sbin
PATH: /usr/bin
PATH: /sbin
PATH: /bin
PATH: /usr/games
PATH: /home/andree/.rvm/bin

Core tests.

configure:2693: checking build system type
configure:2707: result: i686-pc-linux-gnu
configure:2727: checking host system type
configure:2740: result: arm-none-linux-gnueabi
configure:2760: checking target system type
configure:2773: result: arm-unknown-linux-gnueabi
configure:2864: checking for arm-none-linux-gnueabi-gcc
configure:2880: found /home/andree/CodeSourcery/Sourcery_G++_Lite/bin/arm-none-linux-gnueabi-gcc
configure:2891: result: arm-none-linux-gnueabi-gcc
configure:3160: checking for C compiler version
configure:3169: arm-none-linux-gnueabi-gcc –version >&5
arm-none-linux-gnueabi-gcc (Sourcery G++ Lite 2009q1-203) 4.3.3
Copyright (C) 2008 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:3180: $? = 0
configure:3169: arm-none-linux-gnueabi-gcc -v >&5
Using built-in specs.
Target: arm-none-linux-gnueabi
Configured with: /scratch/mitchell/builds/4.3-arm-none-linux-gnueabi-respin/src/gcc-4.3/configure –build=i686-pc-linux-gnu –host=i686-pc-linux-gnu –target=arm-none-linux-gnueabi –enable-threads –disable-libmudflap –disable-libssp –disable-libstdcxx-pch –with-gnu-as –with-gnu-ld –with-specs=’%{funwind-tables|fno-unwind-tables|mabi=*|ffreestanding|nostdlib:;:-funwind-tables}’ –enable-languages=c,c++ –enable-shared –enable-symvers=gnu –enable-__cxa_atexit –with-pkgversion=’Sourcery G++ Lite 2009q1-203′ –with-bugurl=https://support.codesourcery.com/GNUToolchain/ –disable-nls –prefix=/opt/codesourcery –with-sysroot=/opt/codesourcery/arm-none-linux-gnueabi/libc –with-build-sysroot=/scratch/mitchell/builds/4.3-arm-none-linux-gnueabi-respin/lite/install/arm-none-linux-gnueabi/libc –with-gmp=/scratch/mitchell/builds/4.3-arm-none-linux-gnueabi-respin/lite/obj/host-libs-2009q1-203-arm-none-linux-gnueabi-i686-pc-linux-gnu/usr –with-mpfr=/scratch/mitchell/builds/4.3-arm-none-linux-gnueabi-respin/lite/obj/host-libs-2009q1-203-arm-none-linux-gnueabi-i686-pc-linux-gnu/usr –disable-libgomp –enable-poison-system-directories –with-build-time-tools=/scratch/mitchell/builds/4.3-arm-none-linux-gnueabi-respin/lite/install/arm-none-linux-gnueabi/bin –with-build-time-tools=/scratch/mitchell/builds/4.3-arm-none-linux-gnueabi-respin/lite/install/arm-none-linux-gnueabi/bin
Thread model: posix
gcc version 4.3.3 (Sourcery G++ Lite 2009q1-203)
configure:3180: $? = 0
configure:3169: arm-none-linux-gnueabi-gcc -V >&5
arm-none-linux-gnueabi-gcc: ‘-V’ option must have argument
configure:3180: $? = 1
configure:3169: arm-none-linux-gnueabi-gcc -qversion >&5
arm-none-linux-gnueabi-gcc: unrecognized option ‘-qversion’
arm-none-linux-gnueabi-gcc: no input files
configure:3180: $? = 1
configure:3200: checking whether the C compiler works
configure:3222: arm-none-linux-gnueabi-gcc -I/usr/arm-linux-gnueabi/include/gtk-2.0 -I/usr/arm-linux-gnueabi/include/glib-2.0 -lgdk_pixbuf-2.0 -lavcodec -lavutil -lavformat -lswscale -lSDL -lpango-1.0 -lpangoft2-1.0 -lrsvg-2 conftest.c >&5
/home/andree/CodeSourcery/Sourcery_G++_Lite/bin/../lib/gcc/arm-none-linux-gnueabi/4.3.3/../../../../arm-none-linux-gnueabi/bin/ld: cannot find -lgdk_pixbuf-2.0
collect2: ld returned 1 exit status
configure:3226: $? = 1
configure:3264: result: no
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME “libavg”
| #define PACKAGE_TARNAME “libavg”
| #define PACKAGE_VERSION “1.7.1″
| #define PACKAGE_STRING “libavg 1.7.1″
| #define PACKAGE_BUGREPORT “[email protected]”
| #define PACKAGE_URL “”
| /* end confdefs.h. */
|
| int
| main ()
| {
|
| ;
| return 0;
| }
configure:3269: error: in `/home/andree/Bureau/libavg-1.7.1′:
configure:3271: error: C compiler cannot create executables
See `config.log’ for more details

Cache variables.

ac_cv_build=i686-pc-linux-gnu
ac_cv_env_BOOST_PYTHON_LIBS_set=
ac_cv_env_BOOST_PYTHON_LIBS_value=
ac_cv_env_CCC_set=
ac_cv_env_CCC_value=
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=set
ac_cv_env_CFLAGS_value=’-I/usr/arm-linux-gnueabi/include/gtk-2.0 -I/usr/arm-linux-gnueabi/include/glib-2.0′
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_CXXCPP_set=
ac_cv_env_CXXCPP_value=
ac_cv_env_CXXFLAGS_set=set
ac_cv_env_CXXFLAGS_value=’-I/usr/arm-linux-gnueabi/include/gtk-2.0 -I/usr/arm-linux-gnueabi/include/glib-2.0/ -I/usr/arm-linux-gnueabi/lib/glib-2.0/include/ -I/usr/arm-linux-gnueabi/include/pango-1.0 -I/usr/arm-linux-gnueabi/include/cairo/ -I/usr/arm-linux-gnueabi/include/librsvg-2′
ac_cv_env_CXX_set=
ac_cv_env_CXX_value=
ac_cv_env_DC1394_2_CFLAGS_set=
ac_cv_env_DC1394_2_CFLAGS_value=
ac_cv_env_DC1394_2_LIBS_set=
ac_cv_env_DC1394_2_LIBS_value=
ac_cv_env_FFMPEG_CFLAGS_set=set
ac_cv_env_FFMPEG_CFLAGS_value=-I/usr/arm-linux-gnueabi/include/
ac_cv_env_FFMPEG_LIBS_set=set
ac_cv_env_FFMPEG_LIBS_value=-L/usr/arm-linux-gnueabi/lib/
ac_cv_env_FONTCONFIG_CFLAGS_set=set
ac_cv_env_FONTCONFIG_CFLAGS_value=-I/usr/arm-linux-gnueabi/include/
ac_cv_env_FONTCONFIG_LIBS_set=set
ac_cv_env_FONTCONFIG_LIBS_value=-L/usr/arm-linux-gnueabi/lib/
ac_cv_env_GDK_PIXBUF_CFLAGS_set=set
ac_cv_env_GDK_PIXBUF_CFLAGS_value=-I/usr/arm-linux-gnueabi/include/
ac_cv_env_GDK_PIXBUF_LIBS_set=set
ac_cv_env_GDK_PIXBUF_LIBS_value=-L/usr/arm-linux-gnueabi/lib/
ac_cv_env_LDFLAGS_set=set
ac_cv_env_LDFLAGS_value=’-lgdk_pixbuf-2.0 -lavcodec -lavutil -lavformat -lswscale -lSDL -lpango-1.0 -lpangoft2-1.0 -lrsvg-2′
ac_cv_env_LIBRSVG_CFLAGS_set=set
ac_cv_env_LIBRSVG_CFLAGS_value=-I/usr/arm-linux-gnueabi/include/
ac_cv_env_LIBRSVG_LIBS_set=set
ac_cv_env_LIBRSVG_LIBS_value=-L/usr/arm-linux-gnueabi/lib/
ac_cv_env_LIBS_set=
ac_cv_env_LIBS_value=
ac_cv_env_MTDEV_CFLAGS_set=
ac_cv_env_MTDEV_CFLAGS_value=
ac_cv_env_MTDEV_LIBS_set=
ac_cv_env_MTDEV_LIBS_value=
ac_cv_env_PANGOFT2_CFLAGS_set=set
ac_cv_env_PANGOFT2_CFLAGS_value=-I/usr/arm-linux-gnueabi/include/
ac_cv_env_PANGOFT2_LIBS_set=set
ac_cv_env_PANGOFT2_LIBS_value=-L/usr/arm-linux-gnueabi/lib/
ac_cv_env_PKG_CONFIG_set=
ac_cv_env_PKG_CONFIG_value=
ac_cv_env_XI2_1_CFLAGS_set=
ac_cv_env_XI2_1_CFLAGS_value=
ac_cv_env_XI2_1_LIBS_set=
ac_cv_env_XI2_1_LIBS_value=
ac_cv_env_XI2_2_CFLAGS_set=
ac_cv_env_XI2_2_CFLAGS_value=
ac_cv_env_XI2_2_LIBS_set=
ac_cv_env_XI2_2_LIBS_value=
ac_cv_env_XMKMF_set=
ac_cv_env_XMKMF_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=set
ac_cv_env_host_alias_value=arm-none-linux-gnueabi
ac_cv_env_target_alias_set=set
ac_cv_env_target_alias_value=arm-linux-gnueabi
ac_cv_host=arm-none-linux-gnueabi
ac_cv_prog_CC=arm-none-linux-gnueabi-gcc
ac_cv_target=arm-unknown-linux-gnueabi

Output variables.

ACLOCAL=”
AMDEPBACKSLASH=”
AMDEP_FALSE=”
AMDEP_TRUE=”
AMTAR=”
AM_BACKSLASH=”
AM_DEFAULT_VERBOSITY=”
APPLE_FALSE=”
APPLE_TRUE=”
AR=”
AUTOCONF=”
AUTOHEADER=”
AUTOMAKE=”
AWK=”
BOOST_PYTHON_LIBS=”
BOOST_THREAD_LIB=”
CC=’arm-none-linux-gnueabi-gcc’
CCDEPMODE=”
CFLAGS=’-I/usr/arm-linux-gnueabi/include/gtk-2.0 -I/usr/arm-linux-gnueabi/include/glib-2.0′
CPP=”
CPPFLAGS=”
CXX=”
CXXCPP=”
CXXDEPMODE=”
CXXFLAGS=’-I/usr/arm-linux-gnueabi/include/gtk-2.0 -I/usr/arm-linux-gnueabi/include/glib-2.0/ -I/usr/arm-linux-gnueabi/lib/glib-2.0/include/ -I/usr/arm-linux-gnueabi/include/pango-1.0 -I/usr/arm-linux-gnueabi/include/cairo/ -I/usr/arm-linux-gnueabi/include/librsvg-2′
CYGPATH_W=”
DC1394_2_CFLAGS=”
DC1394_2_LIBS=”
DEFS=”
DEPDIR=”
DSYMUTIL=”
DUMPBIN=”
ECHO_C=”
ECHO_N=’-n’
ECHO_T=”
EGREP=”
ENABLE_1394_2_FALSE=”
ENABLE_1394_2_TRUE=”
ENABLE_MTDEV_FALSE=”
ENABLE_MTDEV_TRUE=”
ENABLE_PARPORT_FALSE=”
ENABLE_PARPORT_TRUE=”
ENABLE_V4L2_FALSE=”
ENABLE_V4L2_TRUE=”
EXEEXT=”
FFMPEG_CFLAGS=’-I/usr/arm-linux-gnueabi/include/’
FFMPEG_LIBS=’-L/usr/arm-linux-gnueabi/lib/’
FGREP=”
FONTCONFIG_CFLAGS=’-I/usr/arm-linux-gnueabi/include/’
FONTCONFIG_LIBS=’-L/usr/arm-linux-gnueabi/lib/’
FREETYPE_CFLAGS=”
FREETYPE_CONFIG=”
FREETYPE_LIBS=”
GDK_PIXBUF_CFLAGS=’-I/usr/arm-linux-gnueabi/include/’
GDK_PIXBUF_LIBS=’-L/usr/arm-linux-gnueabi/lib/’
GLU_CFLAGS=”
GLU_LIBS=”
GL_CFLAGS=”
GL_LIBS=”
GREP=”
HAVE_XI2_1_FALSE=”
HAVE_XI2_1_TRUE=”
HAVE_XI2_2_FALSE=”
HAVE_XI2_2_TRUE=”
INSTALL_DATA=”
INSTALL_PROGRAM=”
INSTALL_SCRIPT=”
INSTALL_STRIP_PROGRAM=”
LD=”
LDFLAGS=’-lgdk_pixbuf-2.0 -lavcodec -lavutil -lavformat -lswscale -lSDL -lpango-1.0 -lpangoft2-1.0 -lrsvg-2′
LIBFFMPEG=”
LIBOBJS=”
LIBRSVG_CFLAGS=’-I/usr/arm-linux-gnueabi/include/’
LIBRSVG_LIBS=’-L/usr/arm-linux-gnueabi/lib/’
LIBS=”
LIBTOOL=”
LIBVIDEO_LDADD=”
LIPO=”
LN_S=”
LTLIBOBJS=”
MAKEINFO=”
MKDIR_P=”
MTDEV_CFLAGS=”
MTDEV_LIBS=”
NM=”
NMEDIT=”
OBJC=”
OBJCDEPMODE=”
OBJCFLAGS=”
OBJCLDFLAGS=”
OBJDUMP=”
OBJEXT=”
OTOOL64=”
OTOOL=”
PACKAGE=”
PACKAGE_BUGREPORT=’[email protected]’
PACKAGE_NAME=’libavg’
PACKAGE_STRING=’libavg 1.7.1′
PACKAGE_TARNAME=’libavg’
PACKAGE_URL=”
PACKAGE_VERSION=’1.7.1′
PANGOFT2_CFLAGS=’-I/usr/arm-linux-gnueabi/include/’
PANGOFT2_LIBS=’-L/usr/arm-linux-gnueabi/lib/’
PATH_SEPARATOR=’:’
PKG_CONFIG=”
PREFIX=”
PTHREAD_CC=”
PTHREAD_CFLAGS=”
PTHREAD_LIBS=”
PYTHON=”
PYTHON_EXEC_PREFIX=”
PYTHON_INCLUDES=”
PYTHON_LIBS=”
PYTHON_PLATFORM=”
PYTHON_PREFIX=”
PYTHON_VERSION=”
RANLIB=”
SDL_CFLAGS=”
SDL_CONFIG=”
SDL_LIBS=”
SED=”
SET_MAKE=”
SHELL=’/bin/sh’
STRIP=”
USE_VDPAU_SRC_FALSE=”
USE_VDPAU_SRC_TRUE=”
VERSION=”
XI2_1_CFLAGS=”
XI2_1_LIBS=”
XI2_2_CFLAGS=”
XI2_2_LIBS=”
XMKMF=”
XML2_CFLAGS=”
XML2_CONFIG=”
XML2_LIBS=”
ac_ct_CC=”
ac_ct_CXX=”
ac_ct_DUMPBIN=”
acx_pthread_config=”
am__EXEEXT_FALSE=”
am__EXEEXT_TRUE=”
am__fastdepCC_FALSE=”
am__fastdepCC_TRUE=”
am__fastdepCXX_FALSE=”
am__fastdepCXX_TRUE=”
am__fastdepOBJC_FALSE=”
am__fastdepOBJC_TRUE=”
am__include=”
am__isrc=”
am__leading_dot=”
am__quote=”
am__tar=”
am__untar=”
bindir=’${exec_prefix}/bin’
build=’i686-pc-linux-gnu’
build_alias=”
build_cpu=’i686′
build_os=’linux-gnu’
build_vendor=’pc’
datadir=’${datarootdir}’
datarootdir=’${prefix}/share’
docdir=’${datarootdir}/doc/${PACKAGE_TARNAME}’
dvidir=’${docdir}’
exec_prefix=’NONE’
host=’arm-none-linux-gnueabi’
host_alias=’arm-none-linux-gnueabi’
host_cpu=’arm’
host_os=’linux-gnueabi’
host_vendor=’none’
htmldir=’${docdir}’
includedir=’${prefix}/include’
infodir=’${datarootdir}/info’
install_sh=”
libdir=’${exec_prefix}/lib’
libexecdir=’${exec_prefix}/libexec’
localedir=’${datarootdir}/locale’
localstatedir=’${prefix}/var’
lt_ECHO=’echo’
mandir=’${datarootdir}/man’
mkdir_p=”
oldincludedir=’/usr/include’
pdfdir=’${docdir}’
pkgpyexecdir=”
pkgpythondir=”
prefix=’/home/andree/CodeSourcery/Sourcery_G++_Lite/lib’
program_transform_name=’s,x,x,’
psdir=’${docdir}’
pyexecdir=”
pythondir=”
sbindir=’${exec_prefix}/sbin’
sharedstatedir=’${prefix}/com’
sysconfdir=’${prefix}/etc’
target=’arm-unknown-linux-gnueabi’
target_alias=’arm-linux-gnueabi’
target_cpu=’arm’
target_os=’linux-gnueabi’
target_vendor=’unknown’

confdefs.h.

/* confdefs.h */
#define PACKAGE_NAME “libavg”
#define PACKAGE_TARNAME “libavg”
#define PACKAGE_VERSION “1.7.1″
#define PACKAGE_STRING “libavg 1.7.1″
#define PACKAGE_BUGREPORT “[email protected]”
#define PACKAGE_URL “”

configure: exit 77
2
  • That is a lot of info that is not required I guess. Please try to give the least useful info for the problem.
    – mtk
    Mar 15, 2013 at 9:55
  • i get this errors and i see the synaptic Package Manager i find the libxml2 was installed . The xml2-config script installed by xml2 could not be found *** If xml2 was installed in PREFIX, make sure PREFIX/bin is in *** your path, or set the XML2_CONFIG environment variable to the *** full path to xml2-config. configure: error: libxml2 not found. Aborting.
    – Andree
    Mar 15, 2013 at 14:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .