10

last three days I am experiencing random freezes. If i am looking on youtube when this happens Audio keeps playing but screen is froze and keyboard or cursor do not do anything.

I trying to look in sudo journalctl and this is what I found:

led 04 10:44:02 arch-thinkpad kernel: i915 0000:00:02.0: [drm] *ERROR* Atomic update failure on pipe C (start=113031 end=113032) time 340 us, min 1073, max 1079, scanline start 1062, end 1085
led 04 11:09:15 arch-thinkpad kernel: i915 0000:00:02.0: [drm] *ERROR* Atomic update failure on pipe C (start=203838 end=203839) time 273 us, min 1073, max 1079, scanline start 1072, end 1090
led 04 11:15:47 arch-thinkpad kernel: i915 0000:00:02.0: [drm] *ERROR* Atomic update failure on pipe C (start=227329 end=227330) time 278 us, min 1073, max 1079, scanline start 1066, end 1085

uname -a returns:

Linux arch-thinkpad 5.10.4-arch2-1 #1 SMP PREEMPT Fri, 01 Jan 2021 05:29:53 +0000 x86\_64 GNU/Linux

I use: i3wm, picom, pulseaudio. I have lenovo x390 yoga with intel processor.

How can I diagnose and solve this problem?


EDIT: Upgrading linux kernel to 5.10.16 solved my problem. Still I will accept answer of @Sylvain POULAIN for its complex view on the problemand offering alternative solution.

1
  • 1
    For me, it was also solved on NixOS by upgrading to a newer kernel (5.12 in my case).
    – RikH
    Jul 20, 2021 at 13:31

2 Answers 2

5

5.10.15 doesn't solve this problem. I still have same error. Intel bugs are really annoying since kernel > 4.19.85 (November 2019 !)

As a workaround, i915 guc need to be enable as mentionned in Archlinux Wiki : https://wiki.archlinux.org/index.php/Intel_graphics#Enable_GuC_/_HuC_firmware_loading and loaded before others modules

To resume :

  1. Add guc paramters to kernel parameters by editing /etc/default/grub
GRUB_CMDLINE_LINUX="i915.enable_guc=2"
  1. Add guc option to i915 module by adding /etc/modprobe.d/i915.conf file with :
options i915 enable_guc=2
  1. Add i915 to /etc/mkinitcpio.conf :
MODULES=(i915)
  1. Rebuild kernel initramfs (needs reboot after successfull build) :
# mkinitcpio -P
  1. Remove xf86-video-intel (driver is already in kernel) :
# pacman -Rscn xf86-video-intel
6
  • Thank you for your answer. What should I when I do use systemd boot instead of grub ? Feb 14, 2021 at 23:08
  • 1
    So far, 5.10.15 did solve my problem... 4 days without crash so far.
    – ogr
    Feb 15, 2021 at 7:28
  • 1
    There was an error with contents of /etc/modprobe.d/i915.conf, I have updated it. Consider removing xf86-video-intel package, if you have it installed, as more recent modules are already packed in kernel ... @JanČerný you should edit loader conf, it's well described in archlinux wiki Feb 16, 2021 at 5:18
  • And that, people, is why you don't use or suggest rolling release or fast-paced (less than 2 years cycle) distributions to beginners or if you do serious works that uses "stale" software anyway. There's too much of these kind of "suggestions" and "my update broke something (like Windows 10)" on the web.
    – X.LINK
    Feb 24, 2021 at 12:31
  • @X.LINK : - if you have new material you need recent kernel - you can contribute to kernel feedback - in rolling release you could choose a stable branch kernel instead of still ... Rolling release like manjaro have better kernel management and have more options to chosse one. So your comment about rolling release doesn't make sense. For this problem in this conversation you have the thank you Intel which is the first culprit ... Feb 25, 2021 at 13:10
1

I think I solved it by downgrading linux kernel. I achieved it by installing downgrader package using yay:

yay -S downgrader

Then I ran downgrader linux which game me list of cached versions of kernel:

Downgrade package: linux
1: linux-5.9.arch1-https://archive.archlinux.org/packages/l/linux/linux-5.9.arch1-1-x86_64.pkg.tar.zst  [installed]
2: linux-5.9.9.archhttps://archive.archlinux.org/packages/l/linux/linux-5.9.9.arch1-1-x86_64.pkg.tar.zst  (from ALA)
3: linux-5.9.8.archhttps://archive.archlinux.org/packages/l/linux/linux-5.9.8.arch1-1-x86_64.pkg.tar.zst  (from ALA)
4: linux-5.9.7.archhttps://archive.archlinux.org/packages/l/linux/linux-5.9.7.arch1-1-x86_64.pkg.tar.zst  (from ALA)
5: linux-5.9.6.archhttps://archive.archlinux.org/packages/l/linux/linux-5.9.6.arch1-1-x86_64.pkg.tar.zst  (from ALA)
6: linux-5.9.5.archhttps://archive.archlinux.org/packages/l/linux/linux-5.9.5.arch2-1-x86_64.pkg.tar.zst  (from ALA)
7: linux-5.9.4.archhttps://archive.archlinux.org/packages/l/linux/linux-5.9.4.arch1-1-x86_64.pkg.tar.zst  (from ALA)
8: linux-5.9.3.archhttps://archive.archlinux.org/packages/l/linux/linux-5.9.3.arch1-1-x86_64.pkg.tar.zst  (from ALA)
9: linux-5.9.2.archhttps://archive.archlinux.org/packages/l/linux/linux-5.9.2.arch1-1-x86_64.pkg.tar.zst  (from ALA)
10: linux-5.9.14.archttps://archive.archlinux.org/packages/l/linux/linux-5.9.14.arch1-1-x86_64.pkg.tar.zst  (from ALA)
11: linux-5.9.13.archttps://archive.archlinux.org/packages/l/linux/linux-5.9.13.arch1-1-x86_64.pkg.tar.zst  (from ALA)
12: linux-5.9.12.archttps://archive.archlinux.org/packages/l/linux/linux-5.9.12.arch1-1-x86_64.pkg.tar.zst  (from ALA)
13: linux-5.9.11.archttps://archive.archlinux.org/packages/l/linux/linux-5.9.11.arch2-1-x86_64.pkg.tar.zst  (from ALA)
14: linux-5.9.11.archttps://archive.archlinux.org/packages/l/linux/linux-5.9.11.arch1-1-x86_64.pkg.tar.zst  (from ALA)
15: linux-5.9.10.archttps://archive.archlinux.org/packages/l/linux/linux-5.9.10.arch1-1-x86_64.pkg.tar.zst  (from ALA)
16: linux-5.9.1.archhttps://archive.archlinux.org/packages/l/linux/linux-5.9.1.arch1-1-x86_64.pkg.tar.zst  (from ALA)
17: linux-5.8.arch1-https://archive.archlinux.org/packages/l/linux/linux-5.8.arch1-2-x86_64.pkg.tar.zst  (from ALA)
18: linux-5.8.arch1-https://archive.archlinux.org/packages/l/linux/linux-5.8.arch1-1-x86_64.pkg.tar.zst  (from ALA)
19: linux-5.8.9.archhttps://archive.archlinux.org/packages/l/linux/linux-5.8.9.arch2-1-x86_64.pkg.tar.zst  (from ALA)
20: linux-5.8.9.archhttps://archive.archlinux.org/packages/l/linux/linux-5.8.9.arch1-1-x86_64.pkg.tar.zst  (from ALA)
21: linux-5.8.8.archhttps://archive.archlinux.org/packages/l/linux/linux-5.8.8.arch1-1-x86_64.pkg.tar.zst  (from ALA)
22: linux-5.8.7.archhttps://archive.archlinux.org/packages/l/linux/linux-5.8.7.arch1-1-x86_64.pkg.tar.zst  (from ALA)
23: linux-5.8.6.archhttps://archive.archlinux.org/packages/l/linux/linux-5.8.6.arch1-1-x86_64.pkg.tar.zst  (from ALA)
24: linux-5.8.5.archhttps://archive.archlinux.org/packages/l/linux/linux-5.8.5.arch1-1-x86_64.pkg.tar.zst  (from ALA)
25: linux-5.8.4.archhttps://archive.archlinux.org/packages/l/linux/linux-5.8.4.arch1-1-x86_64.pkg.tar.zst  (from ALA)
26: linux-5.8.3.archhttps://archive.archlinux.org/packages/l/linux/linux-5.8.3.arch1-1-x86_64.pkg.tar.zst  (from ALA)
27: linux-5.8.2.archhttps://archive.archlinux.org/packages/l/linux/linux-5.8.2.arch1-1-x86_64.pkg.tar.zst  (from ALA)
28: linux-5.8.14.archttps://archive.archlinux.org/packages/l/linux/linux-5.8.14.arch1-1-x86_64.pkg.tar.zst  (from ALA)
29: linux-5.8.13.archttps://archive.archlinux.org/packages/l/linux/linux-5.8.13.arch1-1-x86_64.pkg.tar.zst  (from ALA)
30: linux-5.8.12.archttps://archive.archlinux.org/packages/l/linux/linux-5.8.12.arch1-1-x86_64.pkg.tar.zst  (from ALA)

I chosed the first one, proceed to install and sudo reboot. Now when I run uname -a i get:

Linux arch-thinkpad 5.9.0-arch1-1 #1 SMP PREEMPT Mon, 12 Oct 2020 18:52:13 +0000 x86_64 GNU/Linux

I have not experience any freezes since downgrade. If anything happens or I will get better diagnostics of issue I will update this answer.

EDIT: upgrading to 5.10.16 solved the issue

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.