0

After successfully booting Debian (many times), and then installing Linux Mint over it only to boot into a grub menu and not the proper Linux Mint, my laptop (Lenovo IdeaPad 1 11IGL05 81VT) no longer finds any Linux distribution and will no longer boot into any linux distribution.

Here is my complete chain of events:

  1. Windows 10 preinstalled.

  2. Disabled Secure Boot, and installed Debian, over-writing windows.

  3. Tried out Debian, did not like it, installed Linux Mint, over-writing debian.

  4. After the install, the laptop booted into grub and not into Linux Mint. This is where all the issues started.

  5. Tried installing Debian. Would not boot. Would get stuck in boot-loop: System BootOrder Not Found.

  6. Tried installing Arch Linux. Would not boot.

  7. Tried installing Linux Mint again. Would not boot.

  8. Tried installing Microsoft Windows 10. Would boot. 9+. Tried various installs and troubleshooting as described below. Linux distros will never boot.

Troubleshooting I have tried:

  • Resetting BIOS/UEFI
  • Using Bootice on Windows to delete all the linux UEFI boot entries and then reinstalling
  • Formatting the whole disk (eMMC) within Windows recovery
  • Formatting the whole disk with gparted in liveUSB

Partially Successful Workarounds:

When I rename EFI/ubuntu to EFI/boot; and rename grubx64.efi to bootx64.efi, as per this stackoverflow tip https://unix.stackexchange.com/a/519336/416763, I am successfully able to boot into Grub, similar to step (2). Manually booting into linux (per some random instructions) were unsuccessful as I landed in BusyBox, not Linux Mint.

Here is the full log from Boot Repair of Linux Mint: https://pastebin.com/raw/yc1ivNb7

As you can see, it does NOT identify the Linux Mint boot system.

3
  • You have UEFI system and gpt partitioned drive. Only boot live installer in UEFI mode, and set UEFI to boot in UEFI only mode for system once installed. That setting is only for installed system. Your selection in UEFI boot menu is a one time boot setting and can be either UEFI or BIOS. help.ubuntu.com/community/UEFI Do you have Mint installed? Are you using latest Boot-Repair as ppa into your live installer. It has been updated to show MMC drives and you do not show all that data. You should not have to copy /EFI/Ubuntu to /EFI/Boot as grub install adds boot files to /EFI/Boot. – oldfred Jan 3 at 17:27
  • I only boot in UEFI mode. Yes, I have Mint installed. I will download boot repair separately and see if it generates any different logs. – apscience Jan 3 at 17:44
  • Report shows some things in MMC ext4 partition, but report did not show fstab nor full grub.cfg, more as if partial install? Or is report just not showing those normal files? Check /etc/fstab, and /boot/grub/grub.cfg in your ext4 partition. – oldfred Jan 3 at 21:00
1

The fact that you've partially fixed your issue by editing files inside the EFI directory suggests me that you're not selecting the correct partition in your System Boot Order entry in the BIOS (or some other boot entry in it).

If you can incur in the grub instead, but you cannot detect other systems except Linux, os-prober (under Community on Archlinux) is a necessary package that you've missed in your setup process: it allows the grub to detect other OSs. Try to install it and run update-grub again.

0

I have an unsatisfying answer to this: While I was not able to install Ubuntu, Debian, Unix Mint, or Arch Linux, I was successfully able to install MX Linux with the standard installer. It's not clear to me why this is the case.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.