-2

When I try to add any repository I have this error:

root@Hacknonimous:~# sudo add-apt-repository ppa:agornostal/ulauncher  
 Application launcher for Linux
 More info: https://launchpad.net/~agornostal/+archive/ubuntu/ulauncher
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keybox '/tmp/tmpb55cnwbo/pubring.gpg' created  
gpg: /tmp/tmpb55cnwbo/trustdb.gpg: trustdb created  
gpg: key FAF1020699503176: public key "Launchpad PPA for Aleksandr Gornostal" imported  
gpg: Total number processed: 1  
gpg:               imported: 1  
Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).  
**gpg: no valid OpenPGP data found**.
root@Hacknonimous:~# apt update  
Hit:1 http://packages.microsoft.com/repos/vscode stable InRelease  
Ign:2 http://ppa.launchpad.net/agornostal/ulauncher/ubuntu hirsute InRelease                                                                 
Hit:4 http://ftp.debian.org/debian stable InRelease                                                          
Hit:3 http://kali.cs.nctu.edu.tw/kali kali-rolling InRelease               
Err:6 http://ppa.launchpad.net/agornostal/ulauncher/ubuntu hirsute Release  
  404  Not Found [IP: 91.189.95.85 80]  
Hit:5 http://kali.cs.nctu.edu.tw/kali kali-last-snapshot InRelease    
Hit:7 http://kali.cs.nctu.edu.tw/kali kali-experimental InRelease  
Reading package lists... Done  
**E**: The repository 'http://ppa.launchpad.net/agornostal/ulauncher/ubuntu hirsute Release' does not have a Release file.  
**N**: Updating from such a repository can't be done securely, and is therefore disabled by default.  
**N**: See apt-secure(8) manpage for repository creation and user configuration details.  
**W**: Target Packages (non-free/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:3  
**W**: Target Packages (non-free/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:3  
**W**: Target Translations (non-free/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:3  
**W**: Target Translations (non-free/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:3  
**W**: Target DEP-11 (non-free/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:3  
**W**: Target DEP-11 (non-free/dep11/Components-all.yml) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:3  
**W**: Target DEP-11-icons-small (non-free/dep11/icons-48x48.tar) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:3  
**W**: Target DEP-11-icons (non-free/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:3  
**W**: Target Packages (non-free/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:3  
**W**: Target Packages (non-free/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:3  
**W**: Target Translations (non-free/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:3  
**W**: Target Translations (non-free/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:3  
**W**: Target DEP-11 (non-free/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:3  
**W**: Target DEP-11 (non-free/dep11/Components-all.yml) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:3  
**W**: Target DEP-11-icons-small (non-free/dep11/icons-48x48.tar) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:3  
**W**: Target DEP-11-icons (non-free/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:3  
0

W: Target DEP-11-icons (non-free/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:3

You need to edit your /etc/apt/sources.list by removing line numbre 3 which is a duplicate of the first line. apt will print this error if the same source is configured multiple times.

Do not mix kali branches (kali-experimental and kali-last-snapshot).

Remove the Ubuntu repository because it will break your installation.

Non-Kali Repositories

adding other operating system's repositories into Kali (such as trying to put Ubuntu on Kali), will break your installation. This is the single most common reason why Kali Linux systems break

From the terminal:

sudo rm /etc/apt/sources.list.d/*
echo "deb http://http.kali.org/kali kali-rolling main non-free contrib" |sudo tee /etc/apt/sources.list
sudo apt update
2
  • After I have Same Error – Mohammed Nihap Jan 3 at 10:41
  • @MohammedNihap see my update please. – GAD3R Jan 3 at 18:38
-1

This is the relevant line - the only one with an "E"rror:

**E**: The repository 'http://ppa.launchpad.net/agornostal/ulauncher/ubuntu hirsute Release' does not have a Release file.  

The repo is invalid, please contact the maintainer of that repo for a fix.

This can also mean that there is no valid data, e.g. not signed, please see that PGP/GPG error. Try adding their PGP public key manually by getting it from their launchpad site here https://launchpad.net/~agornostal or the Ubuntu keyserver:

https://keyserver.ubuntu.com/pks/lookup?search=0x880ABF3968CAE217558E9B70C28DBAC0C19637D7&fingerprint=on&op=index

https://keyserver.ubuntu.com/pks/lookup?search=0x012EE33B9B951164B8299BABB96482D36BD735B0&fingerprint=on&op=index

(save the key(s) e.g. as agornostal.pub)

and add them like this

sudo apt-key add agornostal.pub

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.