On an older laptop that runs Fedora 18, and has a Intel Corporation 82852/855GM Integrated Graphics Device, I cannot get OpenGL to run on it.

In fact, I have no 3D acceleration whatsoever.

I have the correct drivers installed, but I can't get OpenGL to work.

glxinfo reports:

name of display: :0.0
X Error of failed request:  BadAlloc (insufficient resources for operation)
  Major opcode of failed request:  152 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Serial number of failed request:  22
  Current serial number in output stream:  25

In fact no GLX application will start, all stop with the same error message.

Do I have to enable it in the Kernel or put something into xorg.conf?

As it has been requested, here's my xorg.0.log, and the ouptut of lspci.

closed as off-topic by slm, jasonwryan, Gilles, vonbrand, devnull Mar 23 '14 at 4:54

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – slm, jasonwryan, Gilles, vonbrand, devnull
If this question can be reworded to fit the rules in the help center, please edit the question.

  • (1) In "theory", X11 is very intelligent now that it will start correctly without xorg.conf. As that chip is supported by xserver-xorg-video-intel, X11 should be able to load it correctly. You can try moving the xorg.conf away(rename it) and start restart X11 to see if it does the trick. (2) If the above does not help, post /var/log/Xorg.0.log. – John Siu Jan 28 '13 at 15:48
  • I've uploaded and linked the xorg.0.log file. Moving xorg.conf didn't help... – polemon Jan 29 '13 at 13:01
  • Strange, base on your Xorg.0.log, drive and glx loaded. Line70 GLX loaded Line154 identify chipset correctly Line197 DRI2 loaded Line229 AIGLX initialized. How much memory the video card has? Post your xorg.conf also. – John Siu Jan 29 '13 at 14:52
  • Well, there is no xorg.conf as such. There's just a file inside /etc/X11/xorg.conf.d/00-anaconda-keyboard.conf, which does no settings to the driver part of things... – polemon Jan 29 '13 at 16:49
  • hmm, seems my answer is actually useless, the current intel driver actaully only use uxa. So there is no point(and no use) to add that section. – John Siu Jan 29 '13 at 17:01

You may be hit by a recent mesa 9.x bug/issue [link here].

To check if you are using mesa 9.x

yum list installed | grep mesa

If you have mesa-9.0-3.fc18, try downgrade to mesa-8.1-0.19.fc18.

yum downgrade mesa
  • I found that one myself as well, but I didn't bother downgrading just yet. (Linux Mint Debian Edition was unaffected so I figured it's Ubuntu only) I'll do it just as I find some spare time. – polemon Jan 30 '13 at 11:13
  • Linux Mint still using Mesa 8.x. Fedora 18 upgraded repository last month, that's why you get hit. Fedora is very cutting edge in terms of pacakage upgrade :) – John Siu Jan 30 '13 at 11:15
  • I just tried, bit of a problem, though: I can only downgrade to mesa-dri-drivers-9.0.1-1.fc18.i686. I tried downgrading further, but older packaged are simply not available. At least not from repos, that is. – polemon Jan 30 '13 at 11:37
  • You properly have to download mesa-8.1-0.19.fc18 rpm directly. But all link I search from google seems dead, this is just strange. – John Siu Jan 30 '13 at 13:02
  • That's why I was asking to begin with. It seems the bug kinda sits there, but since the hardware is so old, not many people bother fixing it... – polemon Jan 30 '13 at 13:07

There is no OpenGL hardware support for your card. Try "i915 modeset=1" as an addition to your boot line.

  • Well, there used to be one then, as it worked with Linux Mint just a few days ago... – polemon Jan 29 '13 at 17:40
  • 1
    According to this link, 855GM support OpenGL 1.3. – John Siu Jan 30 '13 at 11:07

Actually, the problem sorted itself. There was an update of Mesa a couple of weeks ago, and it now works beautifully.

Just thought I'd share! :3

Not the answer you're looking for? Browse other questions tagged or ask your own question.