1

I've just tried to upgrade my OpenSuSE Leap 15.0 based home server to 15.2 by using a self-made DVD containing the official image. It failed. First, the installer announced an I/O error whilst trying to install some package (I don't know which, unfortunately), and stopped. When rebooting the system and trying to upgrade for the second time, the installer already stopped at step #3 (repo selection) with the following error message (translated):

Base installation product not found. Installation stopped.

I gave the upgrade a third chance, but received the abovementioned error message. The 15.0 system seemed untouched, but the firewall had to be reinstalled.

Here is my system config:

╭─root@valen ~  
╰─➤  sysinfo -v    
(by hxtools sysinfo) [valen] openSUSE Leap 15.0 | Linux 4.12.14-lp150.12.82-default x86_64 | 8-thr Intel(R) Xeon(R) CPU E3-1231 v3 3800MHz | Load: 0.42 Tasks: 187 | Mem: 234/7931MB | Disk: 809/916GB | Gfx: ASPEED Technology, Inc. ASPEED Graphics Family @ 1920x1080

The DVD was fairly fresh (2 days old), and the burning app (K3b) checked the disc and found no errors.

What's the problem here? Is the DVD maybe faulty despited being declared flawless by K3b?

1

From https://en.opensuse.org/SDB:System_upgrade

Warning: Do not skip a release when upgrading! Example: do not upgrade from 15.0 to 15.2. Instead, from 15.0 upgrade to 15.1, then from 15.1 upgrade to 15.2.

2
  • Yes, but is this really the source of trouble here? I have skipped one or two leaps several times without running into problems like this. – Neppomuk Jan 1 at 22:24
  • I don't know if that's the source of the trouble or not. But, the vendor recommends against it. It might be interesting to find out why they recommend against it - most likely because the upgrade procedure makes certain assumptions about the contents of the system being upgraded, or because they've never tested the 15.0 -> 15.2 upgrade. – stufuller Jan 2 at 23:33
1

After some advice I got on another forum I upgraded the system by using the Zypper tool following this official instruction, so that the server remained online during the one-hour operation. Everything worked fine, and the only thing I couldn't find out is why the DVD upgrade stopped prematurely.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.