1

I am trying to enable XBitHack on my Apache2 web server running on Debian 10. This is what I put in /etc/apache2/apache2.conf:

<Directory /srv/>
        Options Indexes FollowSymLinks
        AllowOverride None
        Options +Includes
        AddType text/html .shtml
        AddHandler server-parsed .shtml
        XBitHack on
        Require all granted
</Directory>

And after restarting apache2.service with systemd, I get told that:

AH00526: Syntax error on line 182 of /etc/apache2/apache2.conf:
Invalid command 'XBitHack', perhaps misspelled or defined by a module not included in the server configuration
Action 'start' failed.

Is there anything I'm missing or doing wrong here?

1 Answer 1

2

You need to enable mod_include in your server.

Run

sudo a2enmod include

to symlink include.load from /etc/apache2/mods-available to the /etc/apache2/mods-enabled directory and restart your server.

You could also merge the Options directive to one line:

Options Indexes FollowSymLinks Includes

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .