2

I tried part of this tutorial and firmly broke my Fedora bootup.

Usually when I boot up, the first thing that happens is I get a screen with my available kernels, I select one, and then it goes to a LUKS password prompt. Then after that it goes blank and then shows the KDE loading icon.

Now I get the GRUB bootloader with all my various kernels from the past and the current one (That stage looks normal). I tried a few of those but in the end, after successful LUKS decrypt prompt, it goes to a blank screen on bootup and that's it. I know the volume is fine since I successfully, decrypted, mounted and copied from the file systems thru live boot.

Here are the changes I made that may have caused this failure:

  1. echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf
  2. Appended ‘rd.driver.blacklist=nouveau’ to end of ‘GRUB_CMDLINE_LINUX=”…”‘. in /etc/sysconfig/grub
  3. grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg (I assumed I was using EFI because I believe that was how I installed it)
  4. dracut /boot/initramfs-$(uname -r).img $(uname -r)
  5. systemctl set-default multi-user.target

I did make a backup of the initramfs image so I will bootup on my backup USB system and move the original back into place and also remove the steps 1 and 2 from above that I appended.

However I am very concerned about having messed with grub and initramfs. The boot process can definitely be fixed, I would say since decrypt goes fine.

Any ideas to try first off?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.