I'm running xubuntu 12.10 (xfce 4.10) (on a lenovo thinkpad X121e) and the function (fn) + volume control do not change the actual output volume. they do something and a volume change is displayed, but It seems to be changing the "HDMI / DisplayPort" (digital stereo, whatever that means...?) but all music seems to be output to "analogue stereo" (whatever that means...?). So what probably want is to remap fn+f1/f2 (the volume control keys) to the audio output (but any other ideas are very welcome too).

how on earth do I do that?

Several users seem to be facing a similar problem, but I have so far not found a sufficient solution, since they all seem to be referring to gnome and most of them address something like "system settings -> sound preferences" which doesn't exist in (my) xfce.

the closest answer I could find I think could be this: No volume control in Nexuiz fullscreen mode does that mean I need to enable or install or whatever acpid and if yes, where and under what name do I save that script? nowhere can I find any such lines. help very welcome, thanks.

1 Answer 1


I am running Arch Linux (with xfce) on a Lenovo W530 and xubuntu (with xfce) on a W500. As I recall on xubuntu the volume keys worked out of the box. On Arch I had to set the keyboard shortcuts manually:

Settings > Keyboard > Application Shortcuts

   amixer set Master +5%    ->    XF86AudioRaiseVolume
   amixer set Master -5%    ->    XF86AudioLowerVolume

amixer has to be installed, of course. While setting the shortcuts, you don't have to type the XF86... commands; just press the key (-combination) you want when creating new shortcut.

  • great work, thanks! Since it worked in command line, I mapped amixer -c 1 sset Master playback 2%+ to XF68raisevolume and amixer -c 1 sset Master playback 2%- to XF68lowervolume in the 'keyboard -> application shortcut' settings (by pressing the desired buttons) now in command line it works, but the 'buttons' (fn+raise/lower volume) do not. I tried mapping the command to a vacant button (winkey + '+' and winkey + '-' respectively) it works. I suspect that I have to get rid of the "original" mapping, or, while I'm at it, edit it (which is what I've been looking for originally) But how?
    – user31220
    Feb 2, 2013 at 12:59
  • sorry this looks awful - don't know how to break lines in comments.
    – user31220
    Feb 2, 2013 at 13:00
  • It' been a while... have you got it working?
    – cee
    Feb 15, 2013 at 19:41
  • Is this command working for you in the terminal amixer -c 1 sset Master playback 2%+ Are you sure it's card number 1? For me it works with amixer -c 0 sset Master playback 2%+
    – cee
    Feb 15, 2013 at 19:44
  • I also didn't succeed to add line breaks :) According to Stackexchange Markdown Help two spaces it the end of a line should do it. Doesn't seem to work here...
    – cee
    Feb 15, 2013 at 19:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.