0

I tried to follow this webpage.

I have become stuck on this: enter image description here

EDIT after advice:

enter image description here

enter image description here

2 Answers 2

2

You need to use apt command (on debian based distributions) rather than yum:

sudo apt install wacom

To build the package you should use :

sudo apt update
sudo apt upgrade
sudo reboot

sudo apt install build-essential autoconf linux-headers-$(uname -r)

Building steps (instructions from : Installing input wacom from source):

wget https://github.com/linuxwacom/input-wacom/releases/download/input-wacom-0.46.0/input-wacom-0.46.0.tar.bz2
tar xvf input-wacom-0.46.0.tar.bz2
cd input-wacom-0.46.0/
#./autogen.sh
if test -x ./autogen.sh; then ./autogen.sh; else ./configure; fi && make && sudo make install || echo "Build Failed"
sudo depmod -a
sudo modprobe -v wacom
sudo modprobe -v wacom_w8001
17
  • 1
    @ElenaGreg Just run xsetwacom --list devices to get information about your device then use xsetwacom --set to configure your stylus.
    – GAD3R
    Commented Dec 27, 2020 at 11:46
  • 1
    Thank you. I didn't need to install xserver-xorg-input-wacom
    – Elena Greg
    Commented Dec 27, 2020 at 12:01
  • 1
    @ElenaGreg It is used to change settings, The driver is already loaded by modprobe command. Try rebooting.
    – GAD3R
    Commented Dec 27, 2020 at 12:05
  • 1
    @ElenaGreg run sudo depmod thensudo modprobe -v wacom
    – GAD3R
    Commented Dec 27, 2020 at 12:32
  • 1
    @ElenaGreg After executing modprobe -v module it will display something like ...ko . This mean that the kernel module is loaded correctly.
    – GAD3R
    Commented Dec 27, 2020 at 12:58
2

As written on the page, that you've mentioned, if you are using Linux Mint(on page shortened as Mint), you should use:

sudo apt-get install build-essential autoconf linux-headers-$(uname -r)

Linux Mint is Debian based, which means, that it uses apt package manager instead of yum package manager used by Red-Hat like Linux distributions (such as Fedora, CentOS, ...)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .