0

So I am running Ubuntu 20.04 on a virtual machine inside Windows 10. A program on Ubuntu needs to have read and write permissions for a folder I mounted via VirtualBox, so I decided to try to chmod the folder. I understand that I can't do that, and have tried sudo setfacl -m /path/to/dir, and got this error: setfacl: Option -m: Invalid argument near character 1. Next, I tried sudo setfacl -m u:user:rwx /path/to/dir, and got this error: setfacl: /path/to/dir/: Operation not supported.

I honestly don't know what else to do, these commands are supposed to be correct but they won't work. Am I doing this wrong? Is there another way to do this? I was thinking of just mounting the hard drive on Linux, but I forgot Linux is just a virtual machine so that won't work, and dual booting is not an option for me.

2

2 Answers 2

2

The first setfacl is wrong. As for the rest acls and Unix modes, are not supported on MS file-systems. Change the permission on the host.

2
  • Could you explain more about changing the permission on the host? I'm not exactly sure how to do that.
    – botnewb
    Commented Dec 25, 2020 at 18:06
  • @botnewb Sorry that is an MS-Windows question. I don't know ether. From what I remember there is a read-only bit (this is a not-write bit). Then there is a very complex ACL system. Commented Dec 27, 2020 at 15:44
0

I got my answer!

Since my program had a user, I just added that user to the vboxsf group and solved my problem. No need for chmod.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .