0

I'm not great at building from source but trying to build the Bionic source package of libpam-ldap on a Ubuntu 18.04 host to fix a timeout issue when using Duo MFA. I issued apt source libpam-ldap and then proceeded to the pam_ldap-186 directory. In the Ubuntu buildlog at the above link, it shows dh_auto_configure and configure being run with these specifics:

dh_auto_configure -- --libdir=/lib/x86_64-linux-gnu --with-ldap-lib=openldap

configure --build=x86_64-linux-gnu --prefix=/usr --includedir=${prefix}/include --mandir=${prefix}/share/man --infodir=${prefix}/share/info --sysconfdir=/etc --localstatedir=/var --disable-silent-rules --libdir=${prefix}/lib/x86_64-linux-gnu --libexecdir=${prefix}/lib/x86_64-linux-gnu --disable-maintainer-mode --disable-dependency-tracking --libdir=/lib/x86_64-linux-gnu --with-ldap-lib=openldap

When I try to run make however, I get this error. It seems to be looking for automake v1.9 but 1.15.1 is what is installed on ubuntu 18.04. Any way to fix this? I'm not terribly familiar with automake and the other build utilities so not sure what to do here:

make cd . && automake-1.9 --gnu Makefile /bin/bash: line 11: automake-1.9: command not found Makefile:196: recipe for target 'Makefile.in' failed make: *** [Makefile.in] Error 127

1

The package build runs autoreconf for you, which will ensure that the build uses your installed autoconf. To use that, instead of figuring out the build commands from logs, run

cd ldap_pam-186
sudo apt build-dep libpam-ldap
dpkg-buildpackage -us -uc

This will produce .deb files in the parent directory.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.