1

This horror story began a week ago when after an update, my Arcolinux install started behaving erratically and some sites (at random) won't open (they would after I left them for a while and tried again. I guessed it to be a DNS issue and looked it up. It seemed that using dnsmasq instead of systemd-resolved helped some people. So, I followed the Archwiki to the letter but now no sites will load. I then did different permutations and combinations of starting, stopping, and restarting systemd-resolved, dnsmasq and NetworkManager, which sometimes seemed to help (around 40% of the time and, as I told you, at random). Then yesterday, I couldn't not get any of the sites load, so I reinstalled the system.

It should have solved the problem but again I encountered the same problems (some sites would not load). Also, I noticed that in the freshly installed system, systemd-resolved was not running by default. I then again tried different permutations and combinations of starting, stopping, and restarting systemd-resolved, dnsmasq and NetworkManager. And again, problem not solved. (In fact, I had to wait for 15 minutes before Unix StackExchange would open).

Their (Arco's) forums seem to be very stagnant and I got no help there. Probably there is a program that manages DNS etc for us?

/etc/resolv.conf:

# Generated by resolvconf
nameserver 192.168.43.1
nameserver 2402:8100:3844::9
nameserver 2001:4860:4860::8888

/etc/hosts

# Host addresses
127.0.0.1  localhost
127.0.1.1  adelie
::1        localhost ip6-localhost ip6-loopback
ff02::1    ip6-allnodes
ff02::2    ip6-allrouters

Edit: I tried connecting other devices to the phone I use as a portable hotspot, and they didn't have the problem.

Edit2: /etc/nsswitch.conf

# Name Service Switch configuration file.
# See nsswitch.conf(5) for details.
# we changed nsswitch.conf to have access to nas servers
# This config file comes from the package filesystem
# Added two & otherwise installation script 140
# from ArcoLinuxD will change it

# This is the original line (minus 2 &)
# hosts: files & mymachines myhostname resolve [!UNAVAIL=return] & dns

# This is our ArcoLinux line
# hosts: files mymachines resolve [!UNAVAIL=return] mdns dns wins myhostname

passwd: files mymachines systemd
group: files mymachines systemd
shadow: files

publickey: files

hosts: files mymachines resolve [!UNAVAIL=return] mdns dns wins myhostname
networks: files

protocols: files
services: files
ethers: files
rpc: files

netgroup: files
7
  • If the problem persisted afer reinstalling, are you sure it's actually a problem with your OS? Do you have any other devices on the same network? Do they work as expected? Could the problem be with the DNS server you have set in your router? – terdon Dec 23 '20 at 12:02
  • @terdon I use my phone as a hotspot and yeah my phone works fine. – Akshat Vats Dec 23 '20 at 12:04
  • And what if you connect another device to your phone in the same way, does that also work fine? – terdon Dec 23 '20 at 12:05
  • @terdon Yeah it does. Also, I tried connecting to another phone and got the same result on my pc. – Akshat Vats Dec 23 '20 at 12:14
  • 1
    Well, dang then. Could you please edit your question and add this information? Especially the fact that you connected another device to the same phone and that did not have the problem. – terdon Dec 23 '20 at 12:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.