0

I'm running KDE Neon for the first time on a virtual machine. The display doesn't fit my windows size, so I went to the display settings and changed them to my monitor size. But after about one second of displaying the correct resolution, it returns to the original incorrect display. I saw a similar question that it has to do with nvidia drivers, but they were not installed.

Edit: I am using VMware workstation 15, and I cannot update.

2 Answers 2

0

I've experienced this before too when using VirtualBox (I'm not sure what you're using, so I'll explain what you can try if you are using VirtualBox).

It's likely that your guest needs more video memory and that you need to switch to VBoxVGA as the graphics controller. You can choose all these options in the VM's settings.

This seems to be an issue with VirtualBox and KDE. If you want to read more, you can check https://www.reddit.com/r/kde/comments/bp11e8/kde_neon_under_virtualbox_changing_screen/.

If your end goal is to have your VM viewport resize to your host's window, you can install VirtualBox Guest Additions on your guest instead of fiddling with the resolution settings.

This also seems to happen when using VMware. If that's the case, increasing video memory and enabling acceleration might also fix it. Read more at https://www.reddit.com/r/kdeneon/comments/bsgn73/vmware_workstation_15_pro_and_kde_neon_display/.

3
  • I’m using VMware, but I will try it! (I should have mentioned that I use VMware in the question) Dec 19, 2020 at 18:56
  • I tried increasing graphics memory, but it didn’t work. Dec 19, 2020 at 19:11
  • Oh, well, in that case, I did find something else: reddit.com/r/kdeneon/comments/bsgn73/… that might help. The idea is that you can try enabling video acceleration. I'll update my answer to mention that.
    – BOB
    Dec 19, 2020 at 19:22
0

When you have VMware Tools (or open-vm-tools) installed, and are using the VMware-specific X11 video driver (there's probably something similar for Wayland too), the display of the virtual machine should automatically adjust to whatever is the current size of the VM console window. Just resize the window to the size you want.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.