I installed BurpSuiteCommunity and the executable went to /opt folder, so I moved it to /usr/bin because /usr/bin is part of my PATH and most of applications were already there. I tried to do run BurpSuiteCommunity in my home folder but it could not find the command. Then I found that the application is actually in /usr/bin/BurpSuiteCommunity/BurpSuiteCommunity. If I were to go into that directory and run BurpSuiteCommunity the application would run.

I tried to make a symlink in /usr/local/bin (which is in my PATH) that points to BSC. If I try to go back to my home folder and type burp I get a message which says

zsh: no such file or directory: ./usr/bin/BurpSuiteCommunity/BurpSuiteCommunity

How can I type burp anywhere and run my application?


This is what I did to fix the problem:

  1. I moved BSC back to /opt as suggested by mikem.

  2. I modified by .zshrc by adding this export statement:

    export PATH=/opt/BurpSuiteCommunity/:$PATH

  3. I then modified by .zshrc again by adding this alias:

    alias burp="BurpSuiteCommunity"

  4. Then I typed zsh to restart the shell. Resolved.

2 Answers 2


It looks like you moved the entire burpsuite into /usr/bin -- as if you did:

mv /opt/BurpSuiteCommunity /usr/bin

Really you just want to add the burpsuite bin directory to your path while leaving burpsuite in it's normal location.

Move burpsuite back to /opt

# mv /usr/bin/BurpSuiteCommunity /opt

Then edit the PATH variable in your $HOME/.bash_profile


Save the .bash_profile and once you're back at your shell, source it:

$ . ./.bash_profile

Once it's in your $PATH, you can execute it from anywhere.

  1. How did you do the symlink? It looks like

    ln -s /opt/BurpSuiteCommunity /usr/bin

    Like this you symlink the folder, you'll likely only need the executable, so try

    ln -s /opt/BurpSuiteCommunity/BurpSuiteCommunity /usr/bin
  2. For some reason your symlink points to


    instead of


    Note the . Your symlink will look for /usr/bin/BurpSuiteCommunity/BurpSuiteCommunity in the directory the symlink sits (i.e. /usr/bin).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .