0

After I implemented an improvised solution to a lack of storage space by moving /var/lib/docker (despite not having docker installed anymore) to another partition, I ran out of root partition disk space again because of a large konsole-...history file.

What could have caused this and how to find out? I deleted the file which was about the size of the moved /var/lib/docker directory which was several GB in size.

Furthermore, the GBs of disk space are still not feed up even though I selected "Delete" and not "Move to Trash" and I don't know why that is. (It's still not cleared after waiting a while and trying to clear memory, cache, free disk space and temporary files with BleachBit. I can run the command sudo du -a / --exclude=/media --exclude=/proc --exclude=/home | sort -n -r | head -n 100 again as I cleared some MB worth of disk space).

I'm using Debian10/KDE.

Update: maybe it's possible to limit konsole-...history filesizes? I found that an open instance of the konsole caused the lack of storage space (due to a large /proc/pid/task/pid/fd file in /proc) even if no command is run in its tabs - I had to close the konsole window and several GBs of disk space were freed up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.